BuddyDev

Search

Maintain Xprofile fields when registering via Google Account


  • Participant
    Level: Master
    Posts: 254
    Daniel on #27048

    Hi guys,

    I am using Google Register next to WP Register.php but when somebody registers via Google, we do not receive all the Xprofile fields (as Birth Date, City etc.). Do you know a plugin that offers to be redirected to a form in order that the user needs to complete the requested data if the user registering via Google in order that we can receive all the additional Xprofile fields?

    Thanks for your input.

    Regards
    Daniel


  • Keymaster
    (BuddyDev Team)
    Posts: 15862
    Brajesh Singh on #27049

    Hi Daniel,
    Please have a look at the BuddyPress profile completion plugin
    https://wordpress.org/plugins/buddypress-profile-completion/

    It may help.

    Regards
    Brajesh


  • Participant
    Level: Master
    Posts: 254
    Daniel on #27053

    Hi Brajesh,

    Nice to meet you again 🙂

    I have installed the plugin and it works well thank you.

    Although there is a bug inside. After the user has filled in all the Xprofile fields, he then is asked to upload his profile picture which works very well because he cannot click anywhere else on the website until he has uploaded his profile pic, but after he has uploaded his profile picture, he is asked to upload the cover photo, but there if the user tries to brows the webpage without uploading the profile cover, the website doesn’t freeze but I receive “Error 404” on each link that the user clicks. Would it be possible to also freeze the website (same as it works for profile pic) until the user has uploaded the cover photo?

    Thanks for your time and for having a look at it.

    Regards
    Daniel


  • Keymaster
    (BuddyDev Team)
    Posts: 15862
    Brajesh Singh on #27057

    Hi Daniel,
    Thank you.
    It’s nice to meet you too 🙂

    Please allow us to check it in next 24 hours and get back to you.

    Regards
    Brajesh


  • Participant
    Level: Master
    Posts: 254
    Daniel on #32000

    Hi,

    Wanted to ask if this issue has been resolved or are you still working on it?

    When ticking that the user must upload coverphoto, then it does not apply on front end.

    Thanks for your input.

    Regards
    Daniel


  • Keymaster
    (BuddyDev Team)
    Posts: 15862
    Brajesh Singh on #32010

    Hi Daniel,
    The cover upload worked for me properly. Is there any chance your cover upload was disabled leading to 404?

    Regards
    Brajesh


  • Participant
    Level: Master
    Posts: 254
    Daniel on #32049

    Hi Brajesh,

    Thanks for your reply. In fact, the plugin asks to upload a profile pic and the user cannot navigate trough the website without uploading a profile pic but after the user has uploaded the profil pic, then the plugin should ask the user to upload a cover photo but it doesn’t, so the user can navigate through the website withou uploading a profile pic. There is no 404 error or other error, just the plugin doesn’t ask to upload a cover photo.

    Thanks for your time.

    Regards
    Daniel

You must be logged in to reply to this topic.

This topic is: not resolved
Subscribe