BuddyDev

BuddyPress and Breadcrumb Trail Plugin Compatibility – Updated

If you are using newer version of BuddyPress(2.6.0 or newer), My old code for adding breadcrumb for BuddyPress components won’t work. It is due to the change in the way BuddyPress Nav items are handled now.

A few years ago, I created a better solution for our Community Builder theme and the Breadcrumb Trail plugin. Here is a slightly modified version of that code. It will work with BuddyPress 2.6.0+

All we are doing is extracting the details for BuddyPress and adding to the trail items.

It is also available as a gist here

https://gist.github.com/sbrajesh/3e1fe81377e9209d694a188e18c1043f

Have fun!

Comments are closed.

Subscribe