BuddyDev

Search

Activity autoloader plugin BUG

  • Participant
    Level: Initiated
    Posts: 1
    George on #25951

    Hey @sbrajesh,

    Thanks for the great plugin.

    I´m currently facing an issue with the plugin “activity autoloader” and “buddypress”: On the site wide activity, I scroll down the first batch of activities and when reaching the bottom it autoloads and displays the second batch (All good till then). Problem is when I sroll down to the bottom of the second batch of activities, reach the bottom again and it does not work. It doesn´t autoload anymore.

    I am wondering if it could be a theme conflict and if you have any hints of where I can start looking at to solve this.

    Thanks in advance!

  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #25960

    Hi George ,
    Welcome to BuddyDev forums.

    Can you please disable the auto loader and try clicking on “Load More” in your activity and see if it loads beyond page 2 or not?

    Please let me know if it does or not?

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 1
    George on #26014

    Hi Brajesh,

    Thanks for your reply.
    Yeah, once the plugin its deactivated activity keeps loading beyond page 2 as normal when pressing the “load more” button.

    BUT I figured out something new when investigating the issue a bit further:

    With plugin active, first batch loads as normal (like in any buddypress). When reaching its bottom, the button “load more” appears pulsing (meaning that it´s loading automaticaly thanks to the plugin). After a few seconds it succesfully loads the 2nd batch.

    BUT from this point, button appears twice following the next scenario (as an example):

    “content from first batch ”
    …………………………………….
    ->Load more button 1 (keeps pulsing)
    …………………………………
    “content from second batch”
    …………………………………
    ->Load more button 2 (does not pulse and it won´t display next batch automatically)

    Note: On my theme, buttons make a pulse animation when they are pressed and being active for loading any content.

    In this scenario, either if I press “Load more button 1” or “Load more button 2”, the 3rd batch loads succesfully, and the scenario described keeps happening again and again with next batches.

    In summary, problem is that after 2nd batch, its is necessary to presss the buttons again. It will not load automatically anymore after 2nd batch.

    Sorry all this sounds a bit confusing, I tried to explain it as clear as possible. If you need any more info or an access to my staging site to see it yourself please let me know 🙂

    Best regards,

  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #26026

    Hi George,
    Thank you.
    Seems something strange with the theme implementation.

    The autoloader plugin simulates click on the end of stream is reached.

    Please contact the theme developer and request them to look for the compatibility.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved