BuddyDev

Search

[Resolved] Auto Friendship Pro – conditions not working

  • Participant
    Level: Initiated
    Posts: 12
    Cofud on #39785

    Hello,

    We’ve just purchased Auto Friendship Pro, but no connection between users is made when conditions are set in the friend list. We’ve tried multiple conditions: role, username, name – none make a successful connection. When no conditions are set, the connection is made successfully.

    Please can you advise? We require users to auto connect by role.

    Many thanks

  • Keymaster
    (BuddyDev Team)
    Posts: 24211
    Brajesh Singh on #39786

    Hi,
    Thank you for purchasing from us.

    1. Are you using BuddyPress or BuddyBoss?
    2. How is the registration happening? Is it via BuddyPress Registration page or admin dashboard or you are using another method?

    Please let me know and I will assist.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    Cofud on #39792

    Hi Brajesh,

    Thanks for the quick response.

    We’re using Buddyboss. The registration is happening through Memberpress – the user is assigned a role through the membership.

    Thank you!

  • Participant
    Level: Initiated
    Posts: 12
    Cofud on #39806

    Hi Brajesh,

    Thanks for the quick response.

    We’re using Buddyboss. The registration is happening through Memberpress – the user is assigned a role through the membership.

    Thank you!

  • Keymaster
    (BuddyDev Team)
    Posts: 24211
    Brajesh Singh on #39808

    Hi Cofud ,
    Thank you for letting me know. The problem seems to be the registration with MemberPress. We can enable role based friendship on it but any rule with other profile field won’t work(the fields are not available when users do not register via BuddyBoss default registration page).

    Please allow me to get back to you with a solution for the MemmberPress and role based friendship in next 24 hours.

    Regards
    Bajesh

  • Participant
    Level: Initiated
    Posts: 12
    Cofud on #39812

    Thanks for all the help Brajesh. Much appreciated!

  • Participant
    Level: Initiated
    Posts: 12
    Cofud on #39853

    Hi Brajesh,

    Were you able to find a solution to this?

    Thank you!

  • Keymaster
    (BuddyDev Team)
    Posts: 24211
    Brajesh Singh on #39855

    Hi,
    Thank you for the patience.

    1. Do you have the option “User Registration” enabled in the settings “Auto Friendship on”
    2. Is there any chance you are using MemberPress to assign different roles on registration based on membership?

    If you are using MemberPress to assign role, we will need to trigger the change on role change as well. Otherwise, just enabling the above condition will work.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    Cofud on #39859

    Hi Brajesh,

    Thanks for getting back.

    1. Yes, ‘user registration’is enabled in the Auto Friendship settings. See attached image.
    2. Yes, we’re using Memberpress to assign different roles on registration based on the various memberships.

    Thank you

  • Keymaster
    (BuddyDev Team)
    Posts: 24211
    Brajesh Singh on #39863

    Thank you.

    I will be releasing an update in couple of hours(or early tomorrow) to provide role change as an option in the settings.

    Regards
    Brajesh

The topic ‘ [Resolved] Auto Friendship Pro – conditions not working’ is closed to new replies.

This topic is: resolved