BuddyDev

Search

[Resolved] Blog only showing one set of comments for all blogs

  • Keymaster
    (BuddyDev Team)
    Posts: 22201
    Brajesh Singh on #16855

    Hi Richard,
    Can you Please try the same on a non production site? I have tested it today with the latets version of BuddyBlog and Bp Simple Front End post and it is working as expected.

    My guess is something is setting up the post id to same value and that’s why the comments seems to be the same.

    PS:- Is there a chance that you are using customized version of the BuddyBlog templates?

    Thank you
    Brajesh

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #16895

    I don’t think I’m using any form of template modification here. I’m only using the following modified templates sitewide.

    wp-content/themes/theme_name/
    ├── buddypress
    │   └── members
    │       ├── index-register.php
    │       └── single
    │           └── home.php
    ├── footer.php
    ├── mediapress
    │   └── default
    │       ├── buddypress
    │       │   └── activity
    │       │       └── views
    │       │           └── grid-photo.php
    │       └── shortcodes
    │           └── grid-photo.php
    

    I’ll take a look at the code and see if there’s a reason the post_id might be modified from somewhere…

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #16896

    Hmmm. I just updated my themes. Even though I’m using a child-theme, maybe that’s introduced some confusion. Will look and feedback…

  • Keymaster
    (BuddyDev Team)
    Posts: 22201
    Brajesh Singh on #16900

    Please do let me know what you find. The above templates does not seem to cause any issue.

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #17002

    hi Brajesh,

    looks like your thoughts on this were correct. I did a massive clean-out, update and refresh, of plugins, first removing them cleanly and then reinstalling several, including removing a number of no longer used ones. Then I began removing the used ones too.

    This appears to have finally resolved the issue/s. All fine at this end, closing…!

  • Keymaster
    (BuddyDev Team)
    Posts: 22201
    Brajesh Singh on #17022

    Hi Richard,
    Thank you for the update.

    Glad it all worked in the end 🙂

    Best Regards
    Brajesh

The topic ‘ [Resolved] Blog only showing one set of comments for all blogs’ is closed to new replies.

This topic is: resolved