BuddyDev

Search

[Resolved] BP AutoLoader loads 7 months ago


  • Participant
    Level: Master
    Posts: 231
    Richard Foley on #20096

    hi Brajesh,

    I’m using your otherwise excellent Activity Autoloader plugin and having some strange results. Versions: AA 1.0.2 with BP 4.1.0 and WP 5.0.2. There are 2 particular cases which are coming up wonky:

    1. When I get to the bottom of the page the next page of results is auto-loaded as expected, but they start from 7 months ago…!

    Vittorio Volpi uploaded 1 new Photo to Fun Photos & Video Images 20 hours ago

    and the next entry (using autoloader) is:

    RobD commented on Drew Berry‘s photo 7 months ago

    2. When I get to the bottom of a user profile or group activity, and AA should be loading the next results, I get:

    Sorry, there was no activity found. Please try a different filter.

    Do you have any idea of what is going on and, more importantly, can we fix this…?

    R.


  • Keymaster
    (BuddyDev Team)
    Posts: 10516
    Brajesh Singh on #20108

    Hi Richard,
    Thank you for posting.

    The plugin was in need of update and was broken with the Nouveau template. Also, the strategy it used was manually handling the loading.

    It was not needed anymore. I have updated the plugin to simulate click on the load more button and now it lets your theme/BuddyPress handle the rest.

    It will work with any theme/template pack now.

    Please give a try to 2.0.0 and let me know.

    https://buddydev.com/plugins/bp-activity-autoloader/

    Regards
    Brajesh


  • Participant
    Level: Master
    Posts: 231
    Richard Foley on #20136

    hi Brajesh,

    glad to have nudged you into an overdue update (and rewrite) of this very useful little plugin. It works fine and just as expected, many thanks!

    Closing.

    R.


  • Participant
    Level: Master
    Posts: 231
    Richard Foley on #20137

    And so quick! 🙂


  • Keymaster
    (BuddyDev Team)
    Posts: 10516
    Brajesh Singh on #20139

    Thank you.
    Yes, I sincerely appreciate that you helped me bring it back to life 🙂

    Regards
    Brajesh

The topic ‘ [Resolved] BP AutoLoader loads 7 months ago’ is closed to new replies.

This topic is: resolved
Subscribe