BuddyDev

Search

BP Groups Tabs Creator Pro

  • Participant
    Level: Initiated
    Posts: 6
    Tim Paschkewitz on #48720

    Hello,

    Last week, I used bpgtc to create a new tab in one specific group. I added three subnavs. In one of the subnavs, I displayed a table of form entries, using a shortcode (wpforms-view). It was working fine – the tabs appeared and the content displayed.

    Yesterday, I was advised that the tabs were present but missing all content. Indeed, I see the same (even when logged in as administrator).

    I also noticed that a different tab I created in the same group (with public display) is no longer showing it’s content.

    I have played around with all the settings in different ways, but no matter what I do, I cannot see any of the content on that tab – I can only see the tab structure – as if the code is working to add tabs and subnavs, but then the content (either done in the tab modifier or as “tab content” is not rendered.

    I am at a loss of what I can do.

    I did recently add “Groups” plugin so that I can conditionally show/hide some menu and widget content by group filter, however, this shouldn’t affect BP to my knowledge. I have even disabled the groups plugin, yet the tab content still does not show, so I don’t think it’s related.

    Any ideas?

  • Participant
    Level: Initiated
    Posts: 6
    Tim Paschkewitz on #48721

    Hello –

    I thought I’d share a screenshot. You’ll see the two tabs I created called “Review” and “Reviewer Resources” are present.

    With “Reviewer Resources” tab selected, you see there is no content. I inspected the page and see a div was created, which I assume holds the content of this tab; however, it’s empty.

    I tried a few things to generate content (in all cases below, I have limited to scope to one group = “Awards Committee”)

    1) Within Group Tabs > Tab Settings I have enabled the tab (and this is working, the tab shows on the group).
    2) Within Group Tabs > Tab Settings > Subnav, I created “Best Practices” with slug “best-practices”, enabled for All, visible for anyone, with content containing text. Nothing shows.
    3) I separately created Group Tabs > Tab Contents > Guidance for Reviewers with the same text content, associated with the “Awards Committee Group” and the Type was a newly created “Reviewer Resources”. I see that this generates the shortcode [bp_dynamic_group_tab_content type=”reviewer-resources”], which I have also entered into the content section in #2, described previously. Nothing renders.

    In fact, I also recently used Profile Tab Creator to create and modify tabs, which perhaps seems to be working for the most part, but I also have some blank tabs in the profile.

    Just thought this might help shed light on the matter. Here is the screenshot: https://seac.online/wp-content/uploads/2021/08/blank-group-tab.png

  • Keymaster
    (BuddyDev Team)
    Posts: 24204
    Brajesh Singh on #48722

    Hi Tim,
    Thank you for using the plugin.

    The issue is indeed caused by Groups plugin.
    Group tabs are stored in custom post type and the groups plugin causes problem with post content.

    Please ask the groups plugin developers on how to disable filtering for the content of a particual post type and that will help solve it.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved