BuddyDev

Search

Buddyblog pay per post expiration issue

  • Participant
    Level: Guru
    Posts: 885
    Tosin on #49434

    Hi Brajesh

    After a user successfully pays for a pay per post product, their post expires within few minutes instead of the value set in the product settings which is 7 days

    This is the image of my settings https://ibb.co/Q6dt0zN

    Im not so sure but will the buddyblog pay per post plugin support the HPOS (High-Performance order storage) woocommerce feature as I have the HPOS feature currently enabled in my site.

    see more at https://woocommerce.com/document/high-performance-order-storage/

  • Keymaster
    (BuddyDev Team)
    Posts: 24204
    Brajesh Singh on #49442

    Hi Tosin,
    Thank you for using the plugin.

    We will need to update the plugin to work with the correct meta in the updatedd wooschema(new tables introduced). This plugin may not work if you have the new schema enabled.

    Since it is still in experimental stage, please expect an update on this in next 2 weeks.
    Also, your expiry issue is related to this one and you will either need to turn off HPOS for our release or avoid using Pay Per post till then.

    Thank you
    Brajesh

  • Participant
    Level: Guru
    Posts: 885
    Tosin on #49580

    I have disabled HPOS but im still experiencing the expiry issue for sticky posts, I have sticky post expiry set to 7 days expiration but paid post are becoming unsticky within few minutes instead of 7 days

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2934
    Ravi on #49582

    Hello Tosin,

    Sorry for the inconvenience. I have checked the plugin with HPOS enabled and disabled modes, and it works fine for me. Please try again and see if there is another plugin or custom code snippet causing this issue. Please let me know if you find anything or not. I will help you.

    Regards
    Ravi

  • Participant
    Level: Guru
    Posts: 885
    Tosin on #49666

    Hi Ravi

    I cant still get it to work with HPOS enabled, kindly confirm if this is how your woocommerce advance settings (Custom data stores) is enabled in the image below.

    https://ibb.co/VDkHRGn

    Only the new WooCommerce orders tables should be enabled.

    Thanks

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2934
    Ravi on #49672

    Hello Tosin,

    Thank you for the acknowledgement. I will give it a try as you suggested and let you know.

    Regards
    Ravi

  • Participant
    Level: Guru
    Posts: 885
    Tosin on #49710

    Hello Ravi

    Have you been able to test this

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2934
    Ravi on #49716

    Hello Tosin,

    Sorry for the delayed reply. I will give it a try and will let you know by the day end.

    Regards
    Ravi

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2934
    Ravi on #49789

    Hello Tosin,

    Sorry for the delayed reply. I have rechecked with HPOS enabled and it is working fine for me i.e. after one day of post publishing, The post is still sticky and marked as unsticky on time. Please try after deactivating all other plugins and custom codes temporarily. If the still persists please share a short video of the issue so that I can check.

    Regards
    Ravi

You must be logged in to reply to this topic.

This topic is: not resolved