BuddyDev

Search

BuddyPress Ajax Registration issue

  • Participant
    Level: Initiated
    Posts: 3
    Vincenzo De Martino on #5286

    Hi, just purchased and installed the plugin,
    heard others had the same problem with a different theme:
    the BuddyPress Ajax Registration keeps loading after hitting register.
    I’m using boss theme by buddy boss
    http://www.buddyboss.com
    Need urgent fix. Thanks in advance

  • Participant
    Level: Initiated
    Posts: 3
    Vincenzo De Martino on #5287

    Forgot to add: although the icon keeps “loading” and nothing happens, the registration completes with no confirmation email and when I refresh the page I’m logged in

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #5288

    Hi,
    My apologies for the inconvenience.
    The problem happens when a theme/plugin company uses the ‘bp_core_activated_user’ inappropriately and add a redirect on it without checking whether a request is coming via ajax or is normal request.

    I have seen it happening with WPLMS theme earlier.

    As far as I checked with Boss 2.2.2, I don’t see any issue. If you are a developer, Please do a search for the ‘bp_core_activated_user’ in your code and let me know if you find something.

    Thank you.
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Vincenzo De Martino on #5294

    Hi Brajesh,

    This code “bp_core_activated_user”, is present in the function- bp.php file

    What can I do to make it work ?

    I hope you can help me because it’s important for my job

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #5295

    Hi Vincenzo,

    It should be written like this

    
    add_Action( 'bp_core_activated_user', 'some_function_name');
    
    

    where the ‘some_function_name’ is name of the attached function. Can you please post me the code for that function and I will be able to help you quickly.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Vincenzo De Martino on #5296

    Hi Brajesh,

    function bbit_auto_follow_users( $user_id ){
    if ( function_exists(‘bp_follow_get_following’) ) :

    // Add your user ids here
    $users_to_follow = array( ‘2’ ); // user id 2 is BossBet

    foreach ( $users_to_follow as $follow_user ) {
    bp_follow_start_following( array( ‘leader_id’ => $follow_user, ‘follower_id’ => $user_id ) );

    // If you don’t want them to follow back remove the line below
    // bp_follow_start_following( array( ‘leader_id’ => $user_id, ‘follower_id’ => $follow_user ) );
    }

    endif;

    }
    add_action(‘bp_core_activated_user’, ‘bbit_auto_follow_users’, 10, 1);

    I have this code to auto – follow after registration .
    Vincenzo

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #5297

    Hi Vincenzo,
    Thank you.

    That code is not doing anything that will cause the problem.

    Can you please point me to your site, Let me first try to register and then I may need temporary access for updating.

    Thank you
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved