BuddyDev

Search

Buddypress auto activate plugin not working.

  • Participant
    Level: Initiated
    Posts: 5
    Christopher Ricci on #34211

    I just bought the auto account activation plugin to bypass the email not being sent issue. Upon creating a new account it still prompted me to activate my account but there is no link in my email still?? Any help to bypass this flawed feature of buddypress would be greatly appreciated.

  • Keymaster
    (BuddyDev Team)
    Posts: 21820
    Brajesh Singh on #34217

    Hi Christopher,
    I am sorry for the inconvenience.

    Is the user registering via BuddyPress registration form? Do you have any plugin liek following:-

    1. User Registration Moderation(e.g. BuddyPress registration Options etc)
    2. Or some plugin that enforces login security( e.g force email or something on that line)
    3. Or a security plugin like Wordfence where you have enabled login security?

    Please let me know and I will assist.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 5
    Christopher Ricci on #34221

    Yes I have security plugins but I’m not using any of their login security features. I’m not using any other registration plugins but I do have a lot of plugins in general. I haven’t found a conflict yet so I figured you guys could take a shot at it? I can provide you with my credentials if you like? Buddypress isn’t sending any emails. Usually gmail wouldn’t receive any but other email providers it would go to their spam. Hopefully we can get the plugin working and bypass their emails all together.

  • Participant
    Level: Initiated
    Posts: 5
    Christopher Ricci on #34223
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21820
    Brajesh Singh on #34224

    Hi Christopher,
    I am looking at the site. Please allow me to get back to you in 30 mins.

    Regards
    Brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 21820
    Brajesh Singh on #34225

    Hi Christopher,
    I have checked and I can see the issue.

    You are using Arcane theme which does not use standard BuddyPress Registration or activation. It also hides the notices from you in admin to give you an impression that the registration is being used.

    Please visit Settings->BuddyPress->Pages and you will not find the option for “registration” and “activation” page while using this theme.

    I am assuming it to be the root issue.

    Solution:- There are 2 possible solutions.
    1. If you switch theme, the plugin will work(I believe that is not the right way since your site is about sports)

    2. Or Please provide me access to the Arcane theme files and I can quickly check if we can integrate our plugin with their registration process.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 5
    Christopher Ricci on #34226
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21820
    Brajesh Singh on #34227
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21820
    Brajesh Singh on #34228

    Hi Christopher,
    Thank you for the patience.

    I had a look at the theme’s code for registration.

    1. It is a custom implementation and there is no way to achieve redirection without modifying the page-user-registration.php

    We have 2 options:-
    1. I can issue the refund for the purchase as the theme is not following any of the basic expectations of BuddyPress

    2. Or, I can modify the theme’s page-user-registration.php and make it work for now. It will be lost in next theme update though.

    Please let me know your thoughts.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 5
    Christopher Ricci on #34231
    This reply has been marked as private.

You must be logged in to reply to this topic.

This topic is: not resolved