BuddyDev

Search

BuddyPress Auto Friendship Pro – Can't get it to work – Part 2

  • Participant
    Level: Enlightened
    Posts: 56
    John B on #32425

    Using my Membership plugin, I submitted a Credit Card transaction and it failed giving me the error message below. When I use a Coupon Code it works. Its only when an actual CC is used that I see the below error.

  • Participant
    Level: Enlightened
    Posts: 56
    John B on #32426
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 56
    John B on #32427

    I’ve asked the Membership plugin author for the hook they are using when a new user is created. I’m hoping that they can provide the hook and it would be feasible to add support for it in BuddyPress Auto Friendship Pro. I’ll update this ticket as soon as I hear back from them.

    Thanks as always, J.C>

  • Keymaster
    (BuddyDev Team)
    Posts: 20151
    Brajesh Singh on #32428

    Hi JC,
    This is related to WordPress 5.5 and BuddyOress. Are you using latest version of BuddyPress(6.2) ?

    WordPress 5.5 has updated PHpMailer library and that will cause this issue with older version of BuddyPress.

    As far as I am aware, this is fixed in 6.2

    Please let me know and I will assist.

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 56
    John B on #32429

    I’m using BuddyPress Version 6.2.0 and WordPress version 5.5.

  • Keymaster
    (BuddyDev Team)
    Posts: 20151
    Brajesh Singh on #32430

    Sorry about this. Just found out that it is a confirmed bug in BuddyPress 6.2 too
    https://buddypress.org/support/topic/phpmailer-class-not-found/

    Let us hope for a new update coming soon.

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 56
    John B on #32444

    Thank you for looking into this.

You must be logged in to reply to this topic.

This topic is: not resolved