Get 15% off on all our plugins, themes and memberships till 4th December. Use coupon: BLACKFRIDAY2021.

BuddyDev

Search

BuddyPress Group Activities Notifier – Failed to send notification with Emoji

  • Participant
    Level: Initiated
    Posts: 7
    Pablo on #41014

    Hello, thank you very much for the plugin! I noticed that the notification is not send when the content of the activity contains an Emoji. Is this a bug? How can I enable emojis for the notifications?

    Thank you

  • Keymaster
    (BuddyDev Team)
    Posts: 19833
    Brajesh Singh on #41021

    Hi Pablo,
    Welcome to BuddyDev.

    Thank you for using the notifier.

    Are you using a custom plugin for adding emoji or is it just normal symbols? Please let me know. I will have better understanding to assist you then.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 7
    Pablo on #41026

    Hello, thank you for the quick reply

    No, but i am using buddybuilder to give buddypress pages the elementor editor.

    here is a pastebin for the system info:
    https://pastebin.com/dKdNr5JW

  • Participant
    Level: Initiated
    Posts: 7
    Pablo on #41087

    Hello. I’ve been testing this further and I’m not too sure what the bug is. I deployed this to our live site and in one occasion the notification and email was sent even though the activity content included a Smile emoji. However it did not work on another activity that included no Emoji but was kind of long, which led me to believe there might also be a character limit to trigger the notification, is that possible?

    I decided to test it further on our staging environment and you can see in the screenshot below which posts triggered a notification and email (for the members)

    https://prnt.sc/1wvg015

    Do you know why this may be happening on some?

  • Keymaster
    (BuddyDev Team)
    Posts: 19833
    Brajesh Singh on #41092

    Hi Pablo,

    Thank you.

    It seems like some utf encoding problem with the sql I am using for bulk insertion. Can you please check your php error log and see if there is any message for database error?

    Please post me the message.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 7
    Pablo on #41107
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19833
    Brajesh Singh on #41121

    Hi Pablo,
    Thank you for the log.

    I am sorry, they don’t show any message related to our insertion. Please allow me to try this on a local setup this weekend and get back to you if I am able to reproduce it.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 7
    Pablo on #41123
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19833
    Brajesh Singh on #41168
    This reply has been marked as private.
  • Participant
    Level: Initiated
    Posts: 7
    Pablo on #41273
    This reply has been marked as private.

You must be logged in to reply to this topic.

This topic is: not resolved