BuddyDev

Search

BuddyPress Message Privacy – v1.0.5 upgrade to v1.0.8 Issues

  • Participant
    Level: Initiated
    Posts: 15
    Carl Hassett on #4921

    Hi Brajesh,

    After updating BP Message Privacy to v1.0.8, it started blocking all messages regardless of user settings or default settings.

    The error message: “There was an error sending that Private Message. Please make sure you fill out both fields.”

    Reverting back to v1.0.5 fix the issue.

    Let me know if there are anyways I can help trouble shoot. Thanks!

  • Keymaster
    (BuddyDev Team)
    Posts: 22202
    Brajesh Singh on #4924

    Hi Carl,
    I am sorry for the inconvenience.

    Which version of BuddyPress are you using?

  • Participant
    Level: Initiated
    Posts: 15
    Carl Hassett on #4926

    Sorry for all the topics today! Big project coming out in a few weeks 🙂

    BuddyPress – Version 2.6.1.1
    WordPress – 4.5.3
    All Plugins Updated
    Theme – TwentyFourteen

  • Keymaster
    (BuddyDev Team)
    Posts: 22202
    Brajesh Singh on #4928

    Hi Carl,
    Thank you. I am looking at it and will have some details in half an hour.

    Thank you
    Brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 22202
    Brajesh Singh on #4930

    Hi Carl,
    I am sorry but I just tested on WordPress Multisite 4.5.3, BuddyPress 2.6.1.1 and BuddyPress Message Privacy 1.0.8. All network active.
    It is working fine.

    Could it be a conflict with the rate limiter plugin?

  • Participant
    Level: Initiated
    Posts: 15
    Carl Hassett on #4932

    Hi Brajesh,

    Thanks for looking into it!

    The only additional relevant information I was able to get are these two warnings:

    Warning: array_filter() expects parameter 1 to be array, string given in /nas/content/staging/username/wp-content/plugins/buddypress-message-privacy/buddypress-message-privacy.phpon line 219

    Warning: Invalid argument supplied for foreach() in /nas/content/staging/username/wp-content/plugins/buddypress-message-privacy/buddypress-message-privacy.php on line 226

    I tested both versions (1.0.5 and 1.0.8) and the warnings only populated when using v1.0.8.

    I did test with “BP Private Message Rate Limiter” deactivated, as well as a few other message plugins, but they didn’t seem to fix the problem. The only plugin that is making testing complicated is https://wordpress.org/plugins/bp-profile-message-ux/ , because it changes the messaging work flow and has some custom integration. However, Private Message v1.0.5 worked with “Bp-profile-message-ux” perfectly.

    Let me know if this information is helpful or if anything else is needed.

    Thanks!
    Carl

  • Participant
    Level: Initiated
    Posts: 15
    Carl Hassett on #4998

    Hi Brajesh

    I’m going to close this support topic because the MediaPress topics are a higher priority than this one.

    I’m going to stick with using ‘Private Message v1.0.5’ unless there are any security concerns that were addressed during the last three updates?

    Thanks for your help!
    Carl

  • Keymaster
    (BuddyDev Team)
    Posts: 22202
    Brajesh Singh on #5012

    Hi Carl,
    Let us not close it. I am believing that it might be a conflict with the UX plugin. Will do a test and then will get back to you.

    Thank you
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved