BuddyDev

Search

Can not edit posts, MediaPress plugin gallery function not showing, and more…

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42682

    Hi,
    New to WordPress/ BBPress so please forgive me.

    I’m having a quite a few issues i can’t seem to resolve.

    1. Keymasters and Admin can not edit posts.

    2. MediaPress plugin gallery function stopped upon upgrading from 2.1.7 to 2.1.8. I tried the new one than went back to the child theme and it ceased to function.

    3. Page-header-mask height looks too big on topics on pc. Height should be the same as in tablet mode. Where to edit CSS?

    4.We’re using GD bbPress Toolbox Pro for a post editor on the forum due to the extended media options. How do I add the Giphy and Emoji butttons to the forum as on BuddyPress?

    See:

    `[link]https://imgur.com/WZVgXA5[/link]

    6.) The GD bbPress Toolbox Pro installed a quote button, but the CSS in Community Builder Pro is making the button background stretch all the way across the post. Where to edit CSS?

    See:

    ‘[link]https://imgur.com/kv2MPyf[/link]

    7.) My Activities and Members pages contain nothing but Title and edit buttons. I can’t figure out how to – for instance – add users with avatars to users page or activities to activity page.

    See:

    ‘{link]https://imgur.com/G8wslVi[/link]

    8.) Need to darken the edit text and lines around posts and replies but the theme editor is unresponsive. Where to edit CSS?

    See Again:

    ‘[link]https://imgur.com/kv2MPyf[/link]

    Thanks in advance.

  • Keymaster
    (BuddyDev Team)
    Posts: 21067
    Brajesh Singh on #42696

    Hi Rob ,
    Welcome to BuddyDev support forums.

    1. Is that for group forums or standalone forums?

    2. I am sorry, that’s not feasible. The 2.1.8 only updates a library used in our theme customizer(alpha colors). There is no side effect on front end as the files are not loaded there. Please check the MediaPress gallery settings and see if it was updated somehow.

    If you still face issue, Please share us with the staging site and we will help.

    3. This is handled via css media query. I will supply you the code. Please help me understand the topic context. Is it independent bbPress forum topic or is it part of group forum topic?

    4.Does GD bbPress Toolbox Pro support emoji or do you mean our emoji support? Currently, our emjoi/giphy support is limited to activity and messages. Did you add those 2 buttons in screenshot or were they added by GD Toolbox plugin?

    6. Sorry about that. Please allow us 2 days to add the compatibility.

    7. Do you have BuddyPress installed. If yes, Please visit Dashboard->Settings->BuddyPress and open the “Pages” tab.

    In that, Please select “Members” page for the members component and “My Activity” page for the activity component. Now, the pages will work as expected.

    8. Please visit Dashboard->Appearance->customize (it may take a little time while that page loads). Please click on “Additional CSS” section and add any custom css there.

    I hope that it helps partially. If possible, Please do provide us with a guest account to your staging site. That will help us help you with the first 2 issues quickly.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42716

    Hi,The
    Thanks for the quick response!

    #1. “Is that for group forums or standalone forums?”

    ———————————————————————————
    We just have one forum where all topics go. I should be more specific, the edit function at the top of the page works fine – the “EDIT” that doesn’t work is located in the lower right corner of each of the replies.
    ———————————————————————————
    #2. “I am sorry, that’s not feasible. The 2.1.8 only updates a library used in our theme customizer(alpha colors). There is no side effect on front end as the files are not loaded there. Please check the MediaPress gallery settings and see if it was updated somehow.

    If you still face issue, Please share us with the staging site and we will help.”
    ———————————————————————————

    Okay, I’ll try uninstalling/reinstalling the plugin and perhaps that may solve it, if not I’ll be glad to let you have a look at it.

    ———————————————————————————
    #3. This is handled via css media query. I will supply you the code. Please help me understand the topic context. Is it independent bbPress forum topic or is it part of group forum topic?

    ———————————————————————————

    Not sure if I understand, but I’m running a BuddyPress and BBPress combo with just a single forum. Each Independent forum topic has an extremely tall Page-header-mask or blue area at top of posts. It looks great in tablet mode, it’s about +/-115px in height but in PC mode it’s taking up a very large portion of the page.

    Please see the screenshot at this link:

    https://imgur.com/0snWC1J
    ———————————————————————————

    #4.Does GD bbPress Toolbox Pro support emoji or do you mean our emoji support? Currently, our emjoi/giphy support is limited to activity and messages. Did you add those 2 buttons in screenshot or were they added by GD Toolbox plugin?

    ———————————————————————————

    No it doesn’t support emoji or Giphy. That’s why I wanted some method to add the Community Builder Pro emoji and Giphy plugins to the GD bbPress Toolbox Pro post editor in the forum. The location of the extra buttons was just photoshopped by me as an example of where I’d like to have them for the sake of clarity.
    ———————————————————————————

    #6. 6. Sorry about that. Please allow us 2 days to add the compatibility.

    ———————————————————————————

    No problems – sounds great and Thanks!

    ———————————————————————————

    # Do you have BuddyPress installed. If yes, Please visit Dashboard->Settings->BuddyPress and open the “Pages” tab.

    In that, Please select “Members” page for the members component and “My Activity” page for the activity component. Now, the pages will work as expected.

    ———————————————————————————

    Thanks! Will do.

    ———————————————————————————

    #8. Please visit Dashboard->Appearance->customize (it may take a little time while that page loads). Please click on “Additional CSS” section and add any custom css there.

    I hope that it helps partially.

    If possible, Please do provide us with a guest account to your staging site. That will help us help you with the first 2 issues quickly.

    ———————————————————————————

    It’s been very helpful, I would like some method to get those plugins working on the forum editor, would that fell under customization?

    I can set you up with an account, can I give you the login info via the contact form here on the website so it’s private?

    Thanks for all your help!

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42729

    Hello again,

    Additionally we found a strange occurrence with registration.On filling out the registration form all goes well.The registration email is sent and received by the intended recipient just fine.When the user follows the link to activate the account it throws up a 404 page not found error.
    So basically, users can not activate their accounts.

    Plus we get a “One or more recommended modules are missing” in site health
    The optional module, imagick, is not installed, or has been disabled. We also get “A scheduled event is late” and “The authorization header is missing.” These may not have anything to do with the theme but thought I’d ask before attempting to fix.

    Best Regards

  • Keymaster
    (BuddyDev Team)
    Posts: 21067
    Brajesh Singh on #42745

    Hi Rob,
    Thank you.

    1. Not sure why, will be able to have better idea afetr looking at it.

    2. Thank you.

    3. Thank you. Do you only need to do it for the bbPress section? If yes, Please let me know or do you want it for the whole site? Just need confirmation before putting the css.

    4. I am sorry, The feature is not supported and we don’t have enough resource to add support for GD tools currently. We will look into it in future. If you need it urgently(in couple of weeks), they will fall under customization.

    6. I am sorry, I was away for a day. Please expect the update on Monday.

    Please share a sample of the activation link. I see that the activation page on your site is functional but the url is using trailing slash, so just need to confirm the link used for activation .

    For the “imagick”, I will suggest installing and enabling it. It is recommended by WordPress for better processing of images.

    For “A scheduled event is late”:- There are several possible reasons. Does the site have enough traffic? The WP cron jobs are triggered by site visit(unless you have configured the cron job by OS).

    For the authorization header issue, you may want to take a look at this
    https://digwp.com/2021/01/fix-site-health-error-authorization-header-missing/

    and see if that works.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42766

    Hi Brajesh,

    Good news I solved most of my issues with adding additional CSS, and the email issues were fixed as well.

    The only things left are the Mediapress issue where I get the message:

    “The following active BuddyPress Components do not have associated WordPress Pages: Gallery, Activate. Repair” And upon attempting to repair there is no “gallery” to add to the page.

    The small EDIT links on the individual posts that users and admin can use doesn’t work.

    As far as the giphy and emoji’s I’ll hold off and let you fix those as your time permits.

    One other thing, I’m sending you new login information from the contact page here on the website.

    Thanks and best regards

  • Keymaster
    (BuddyDev Team)
    Posts: 21067
    Brajesh Singh on #42767

    Hi Rob,
    Thank you.

    I am glad most of the issues were resolved.

    I had a look and I could see that the problem with editing was related to permalink. You had index.php as part of url (in Dashboard->Settings->Permalinks) and that was confusing bbPress(the forum software being used).

    I removed the index.php part from there and the editing is working. Please check.

    The notice about Associated pages:
    “Activate” -> You had registration enabled but activation page not selected. I created an empty page and selected in the Dashboard->Settings->BuddyPress->Pages scree.

    “Gallery”-> Do you need gallery directory on the site? If not, we can disable it form MediaPress settings. Otherwise, we can create another empty page and associate with it on the BuddyPress Pages screen.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42801

    Hi Brajesh,

    Sorry I couldn’t get back to you yesterday.

    Yes we need a gallery that everyone can contribute to if they want.

    We’ve tried to make one several times but it ends up showing just the photos of who created it.

    I think it’s a shotcodes issue.

    One other issue and I do not know if it’s theme related but I’ll ask anyway…

    We’re having a problem with posting images youtubes etc for users that are non keymaster and admin.

    It boils down to the fact the editor is spitting out bbcode on the phone…

    see screenshot @ link: https://imgur.com/a/YhDdf6x

    Which allows everybody to post giphy YouTube etc…(with no attachment ability for guests)and that’s 100% what we want – but…

    On the PC side it spits out html

    see screenshot @ link: https://imgur.com/zPH1lwd

    As a result, nobody can post anything except text because only Admin and keymasters can post html.

    So, on the phone things are good bbcodes seems to work, but not on PC.

    I have no idea if the Giphy plugin on the buddy press end is conflicting with the editor, or this is totally in the GD bbPress Toolbox Pro end of things.

    At any rate, we need just bbcodes to function in the editor and don’t know how to accomplish that. Just let us know if we need to contact the Dev4Press people about the editor.

    Thank a million!

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42802

    Hi again,

    One other small issue is width (in pixels) of inserted media.

    I’d like to keep images and videos at about 500px in width as to not break the layout.

    How can I go about this?

    Is there a plugin or a CSS fix for this?

    Best Regards

  • Participant
    Level: Initiated
    Posts: 15
    Rob on #42807

    Update: We solved our BBCodes problem, it works great now.
    Please disregard that part of what I wrote.
    Thanks!

You must be logged in to reply to this topic.

This topic is: not resolved