BuddyDev

Search

[Resolved] Cannot upload a JPEG file larger than 2 MB

  • Participant
    Level: Enlightened
    Posts: 79
    Leo on #1693

    Hi,

    I am unable to upload a media (image) larger than 2MB, the file size limit is 8MB however I cannot make it. Can you help me figure it out?
    I checked in php.ini file, the limit is 40MB, also I can upload a media to WordPress directly larger than 2 MB.

    Thank you!
    Leo

  • Keymaster
    (BuddyDev Team)
    Posts: 22512
    Brajesh Singh on #1694

    Hi Leo,
    Welcome to BuddyDev forums.

    Did you see any error message? By directly, you mean using WordPress Media Uploader?

    Also, can you please visit Dashboard->MediaPress->tools and post me the debug message?

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 79
    Leo on #1696

    Hi Brajesh,

    Thanks for a super quick response!

    Here’s the error message: image.jpg(2.1 mb)x An error occurred in the upload. Please try again later.
    (I tried later, too, all the same)

    Yes, it is possible to upload a file using WordPress Media Uploader.

    and here’s the debug message:

    // Generated by the MediaPress Debug tool //

    Multisite: No

    SITE_URL: http://ohhmysite.com
    HOME_URL: http://ohhmysite.com

    WordPress Version: 4.3.1
    Permalink Structure: /%postname%/

    Active Theme: Avada 3.5.3

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit

    // Browser Details //
    Browser Name: Chrome
    Browser Version: 46.0.2490.86
    Browser User Agent String: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36
    Platform: Apple
    // End Browser Section //

    PHP Version: 5.5.30
    MySQL Version: 5.1.73-log
    Web Server Info: Apache

    WordPress Memory Limit: 40M
    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Upload Max Size: 40M
    PHP Post Max Size: 8M
    PHP Upload Max Filesize: 40M
    PHP Time Limit: 50000
    PHP Max Input Vars: 5000
    PHP Arg Separator: &
    PHP Allow URL File Open: Yes
    WP_DEBUG: Disabled
    SCRIPT_DEBUG: Disabled

    // Table Prefix //
    Table Prefix: wp_3476fdb5c_

    Show On Front: posts
    Page On Front: (#0)
    Page For Posts: (#0)

    Session: Enabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: On

    DISPLAY ERRORS: On (1)
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.

    ACTIVE PLUGINS:

    BuddyPress: 2.4.0
    BuddyPress Follow: 1.2.1
    Buddypress Profile Rating: 1.0
    BuddyPress Xprofile Custom Fields Type: 2.3.0
    Contact Form 7: 4.3
    Contact Form 7 – Dynamic Text Extension: 2.0.1
    Fusion Core: 1.4.3
    MediaPress: 1.0 Beta 1
    Password Protected: 2.0.2
    rtMedia for WordPress, BuddyPress and bbPress: 3.9.3

    // MediaPress Settings //

    active_components: sitewide,members
    default_status: public
    active_statuses: public
    active_types: photo
    extensions: jpeg,jpg,gif,png,mp4,flv,mpeg,mp3,wmv,midi,zip,gz,doc,pdf,docx,xls
    mpp_upload_space: 100
    mpp_upload_space_groups: 10
    show_upload_quota: 0
    default_storage: local
    enable_gallery_archive: 1
    gallery_archive_slug: exhibitions
    gallery_permalink_slug: exhibition
    sitewide_active_types: photo
    sitewide_photo_gallery_default_view: default
    has_gallery_directory: 1
    has_media_directory: 0
    activity_upload: 0
    autopublish_activities: create_gallery
    activity_photo_default_view: default
    show_orphaned_media: 0
    delete_orphaned_media: 0
    members_active_types: photo
    members_photo_gallery_default_view: default
    galleries_per_page: 20
    media_per_page: 20
    media_columns: 4
    gallery_columns: 4
    show_gallery_description: 1
    show_media_description: 1
    enable_audio_playlist: 1
    enable_video_playlist: 1
    enable_media_comment: 1
    enable_gallery_comment: 1
    load_lightbox: 1
    enable_activity_lightbox: 1

    // End of MediaPress Settings //

    Thank you,
    Leo

  • Keymaster
    (BuddyDev Team)
    Posts: 22512
    Brajesh Singh on #1697

    Hi Leo,
    Thank you.

    1. Your settings are fine and plugin should allow you uploading upto 8 MB( a little less than that) due to your post max size.

    The error you mentioned is not generated server side, It is show when the response from server is not valid JSON.

    So, I am believing that some code is throwing notice causing this. Can you please open your browser console and check for the ajax response. It would have been very simple if you were using firefox/firebug but here is how to Do that on chrome.

    Open the page where upload is. Now click ctrl+shift+I that will open the developer tools. Click on Network panel and keep that open.
    Now please try uploading. As soon as you get the error, click on “XHR” tab and then on the link in Name panel. In right panel, you can see the response by clicking on 3rd tab “Response”. Please post me that message.

    Thank you.

    PS: I see you have RT media enabled, is there any specific reason to use both these plugins together?

  • Participant
    Level: Enlightened
    Posts: 79
    Leo on #1704

    Hi Brajesh,
    Thank you.

    I did it all. When I click on a link in the Name column and select the Response tab, there’s only one number – 1 and an empty row. Hope this is what you needed.

    About the rtMedia, I am trying to find a solution for having different galleries with different limitations and membership levels for different users, and I really would like to do it with one plugin only, but I couldn’t do it with only rtMedia. Now I am trying to do it all with MediaPress and hope to succeed.

    Thank you.

    Leo

  • Keymaster
    (BuddyDev Team)
    Posts: 22512
    Brajesh Singh on #1705

    Hi Leo,
    Thank you for your patience.

    That -1 means the request was not handled at all.
    Can you please disable RT Media and and enable WP_DEBUG to let us see if there are any error?

    Also, if feasible, please PM me the site url/login details( any temporary normal user) and I can check it quickly.

    Thank you
    Brajesh

    PS: Except for Add from Web( which we haven’t added yet), MediaPress can do everything more efficiently than other media plugin. You can check that by doing memory/query analysis. So, if you don’t need Add From web for now, You can disable RT Media.

  • Participant
    Level: Enlightened
    Posts: 79
    Leo on #1706

    Hi Brajesh,

    I disabled the rtMedia and the upload was completed successfully. Everything is fine now.

    As for now, I do not need the Add from Web feature, so I will try to make it all using MediaPress now and will share my experience and the results with you when I finish it.

    Thank you!
    Leo

  • Keymaster
    (BuddyDev Team)
    Posts: 22512
    Brajesh Singh on #1707

    Hi Leo,
    Thank you. I am glad it is fixed.
    I am looking forward to hear your feedback. we have still a lot of things to add and every experience counts 🙂

    I am marking this topic as resolved now. Please do open new topic if you need any further assistance.

    Thank you
    Brajesh

The topic ‘ [Resolved] Cannot upload a JPEG file larger than 2 MB’ is closed to new replies.

This topic is: resolved