BuddyDev

Search

[Resolved] Can't log in, ERROR: Cookies are blocked due to unexpected output.

  • Participant
    Level: Guru
    Posts: 995
    calu on #18280

    Hi Brajesh, after my web hotel was moved to a new host server, I am not able to log in to WP, not as administrator or user, while BuddyPress is activated. All other 3rd party plugins are fine.

    Deactivating BuddyPress solves the problem. So core BuddyPress causes this conflict, with this error message: ERROR: Cookies are blocked due to unexpected output.

    I am not able to create a topic on buddypress.org at the momnet, so I would like your advice on what is wrong. Have you heard of this issue before?

    Regards
    Carsten

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #18282

    Hi Carsten,
    I am sorry to hear about the issue.

    I will suggest two things:-

    1. Make sure you have cleared object caches if any.
    2. Clear your browser cache(or use incognito). Or you can delete cookie for the site specifically.

    After that, try logging again.

    The issue happens when WordPress is unable to detect the Test Cookie on login pages. And Yes, I have seen it earlier but it was something else in my case.

    PS:- If you want, you can inspect cookies under “Application” tab in chrome developer console.

    Regards
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #18293

    Hi Brajesh, thanks for your prompt reply, I will look into this.
    If it is a cookie issue, is it then plausible that it applies to all platforms, different browsers on desktop, tablet and phone?

    Regards
    Carsten

  • Participant
    Level: Guru
    Posts: 995
    calu on #18294

    chrome developer console, is it in developers.google.com, or an add on to the Chrome browser?

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #18296

    Hi Carsten,

    I went through your message again and I see that it is blocked dues to unexpected output and not the cookie not supported.

    In this case, most probably something is sending output early and leading to this. I will suggest using WP Staging plugin and then disabling BuddyPress dependent plugins one by one on the staging site and identifying the cause.

    Since you have moved host, there may be a plugin throwing notice due to configurations.

    For the developer tool, I was referring to this
    https://developers.google.com/web/tools/chrome-devtools/

    But you don’t need to look at cookie in this case.

    Regards
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #18297

    Thanks, I do not think it is a cookie thing either.
    I will download the WP Staging plugin and follow your advice. All BuddyPress related plugins are good, but BuddyPress itself.
    I was about to ask you if any cleaner plugin could do the job

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #18298

    Hi Carsten,
    You are welcome.

    I doubt that it is BuddyPress. It might be but there is a very small chance.

    The reason you might have identified BuddyPress is all BuddyPress dependent plugins only do meaningful things when BuddyPress is active. If BuddyPress is not active, they might not be doing anything and that’s why.

    Please try the isolation and deactivation to find and let me know. I may be able to assist further.

    Thank you
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #18299

    I have installed WP Staging and copied the site files. The problem I am facing now, is that I am not able able to log in to my staging site either?

    I must try to deactivate BuddyPress, and copy again, or disable the plugin via FTP to get in.

    Regards
    Carsten

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #18300

    Hi Carsten,
    You may deactivate BuddyPress, create staging and reactivate it after logging in. That way, you won’t need ftp.

    Regards
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #18301

    I am trying to login on my staging page in another browser, and as non administrator, which is convenient when testing log in, but apparently this is not possible, it has to be in the same browser as main site?

You must be logged in to reply to this topic.

This topic is: resolved