BuddyDev

Search

Conditional Profile Fields – ALL Fields are displayed.

  • Participant
    Level: Initiated
    Posts: 3
    Raz on #14808

    Hi All,

    i have Conditional Profile Fields Version 1.2.1 with Buddypress Version 2.9.4 on lastest version of WP.
    I am using WPLMS theme and created Custom Registration Forms for different member types (Student / Instructor). So in BuddyPress settings the default registration points to a blank page (this allows me to use my own pages with custom registration forms).

    Now, under the Profile Fields i have a Group for Students amd added a bunch of fields. I added conditions to a few fields but on the page, I can see ALL FIELDS.

    Site is private – under development now so i don’t have a link for you to see.
    Do you know if there’s a bug in the latest version of this plugin ? or why all the conditional fields are displayed ?

    Thanks.

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #14812

    Hi Raz,
    Are you using custom profile field types? The plugin may not work as expected with custom field types.

    If you can provide more details, It will help me assist you.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Raz on #14814

    In Profile Fields I setup a new Group named “Students”.
    I added textfields and radio button fields.
    I set the logic like this: if radio YES then show textfield 1. If radio NO then show textfield 2.

    Now in page, when I display the registration form, i see everything: YES NO textfield1 textfield2

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #14815

    Can you please try the same with the First Field Group. I am not sure if the plugin works for other field groups(should work I am assuming). Also, please open your browser console and check to see if you see any javascript error on the edit profile page.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Raz on #14816

    same thing.
    i added test fields in the 1st group – the default one.

    java console doesn’t show errors

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #14817

    Thank you.
    Did the conditions work in the first group or they don’t work here too?

  • Participant
    Level: Initiated
    Posts: 3
    Raz on #14819

    no they did not.

  • Keymaster
    (BuddyDev Team)
    Posts: 21837
    Brajesh Singh on #14820

    In that case I am unable to assist unless I see it.

    It is guaranteed to work in the first group unless something else is causing the problem.

    I will suggest testing finding the conflict by temporarily switching the theme/disabling plugins. Once we can find the conflict, we can certainly resolve it.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved