BuddyDev

Search

[Conditional Profile Fields for BuddyPress] Issues after BuddyPress 3 upgrade

  • Participant
    Level: Initiated
    Posts: 2
    Battle Medialab on #16700

    We’re using your plugin to add conditional logic to the BuddyPress profile editing forms. After upgrading to BuddyPress 3 (as well as applying the latest update for this plugin), we noticed the conditional logic isn’t working properly.

    Let’s say we have Group A, B and C in one series of checkbox elements. Each of these “groups” has a “child” section that corresponds to it and should only show if its “group” is selected. So if Group A is checked, Child A would also show, and if Group A & B are checked, both of their children would show.

    Post-update, if I check Group C, it will reveal Child C but *also* is hiding Child A & B. The odd thing is that if I select something in Child C and save, it shows them all as intended.

    I noticed BuddyPress changed a fair bit of how the forms render, so I have a feeling that may be the culprit.

  • Participant
    Level: Initiated
    Posts: 2
    Battle Medialab on #16703

    I forgot to mention this is a WP Multi-Site setup, if that changes things at all.

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16704

    Hi,
    Welcome to BuddyDev.

    If I understand the problem is related to multicheck where more than one checkbox is ticked, It is not working as expected. Please correct me if I am wrong here.

    Allow me 24 hours to test and post an update, It is most probably a bug in our current version.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 2
    Battle Medialab on #16705

    That is the issue is as you said, yes. If it’s a multi-checkbox group they’re contained in, it isn’t working when 2+ are checked.

    I’ll standby for an update. Thank you for the quick response. 🙂

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16715

    Thank you for the patience.

    Please upgrade to 1.2.2

    https://buddydev.com/plugins/conditional-profile-fields-for-buddypress/

    After that, please make sure to clear any cache(if you are using caching) and try it. It will work.

    Let me know how it goes for you.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved