BuddyDev

Search

Disable Activation Email for new users and activate their account on signup

  • Participant
    Level: Initiated
    Posts: 3
    Dorian Logan on #40583

    Is there a plugin / snippet that can be used to disable the round trip email. We are using a third party platform to authenticate the user so the activation email etc is not needed.

    I have seen comments about disabling the email from being sent – but it does not seems to solve the issue of the account being activated.

    Our use case
    – user fills in reg form
    – validate form
    – call to 3rd party platform to register user
    – platform validates request
    – user created, activated and logged in (no email)

    All advice greatly received.

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #40585

    Hi Dorian,
    Thank you for the question.

    Can you please tell me which of the emails(activatioh, welcome etc) you need to be disabled. We can do it quickly with a couple of lines of code.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Dorian Logan on #43608

    Hi,

    This thread went quiet – as we managed to disable the activation email and associated process. Sadly our approach has stopped working with recent updates from BuddyBoss Plugin.

    What would you recommend?

    We are logging our users in via a 3rd party endpoint (custom) they are already validated etc.

    D.

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #43646

    Hi Dorian,
    Welcome back.

    can you please share what did you do to disable the activation email earlier? That will help help me assist you better.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Dorian Logan on #43651

    We are doing the following

    To disable activation email, add following line to child-theme’s functions.php
    — add_filter( ‘bp_core_signup_send_activation_key’, ‘__return_false’ );

    After deactivating activation, user should be directly activated. So add following line to wp-config.php
    — define( ‘BP_SIGNUPS_SKIP_USER_CREATION’, true );

You must be logged in to reply to this topic.

This topic is: not resolved