BuddyDev

Search

Fatal Error on installation of BuddyPress Member Types Pro

  • Participant
    Level: Initiated
    Posts: 4
    Heather Dow on #45892

    I disabled all of the plugins except for buddypress and still got this error when I tried to install it:

    ` Fatal error: Uncaught Error: Class ‘BP_XProfile_Field_Type’ not found in /home/fourdegr/public_html/ccae/wp-content/plugins/buddypress-member-types-pro/core/field/class-bpmtp-xprofile-field-type-member-type.php:11 Stack trace: #0 /home/fourdegr/public_html/ccae/wp-content/plugins/buddypress-member-types-pro/bp-member-types-pro.php(127): require_once() #1 /home/fourdegr/public_html/ccae/wp-includes/class-wp-hook.php(307): BPMTP_Member_Types_Pro->load(”) #2 /home/fourdegr/public_html/ccae/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #3 /home/fourdegr/public_html/ccae/wp-includes/plugin.php(476): WP_Hook->do_action(Array) #4 /home/fourdegr/public_html/ccae/wp-content/plugins/buddypress/bp-core/bp-core-dependency.php(333): do_action(‘bp_loaded’) #5 /home/fourdegr/public_html/ccae/wp-includes/class-wp-hook.php(307): bp_loaded(”) #6 /home/fourdegr/public_html/ccae/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #7 /home/fourdegr/public_html/ccae/wp-includes/plugin.php(476): W in /home/fourdegr/public_html/ccae/wp-content/plugins/buddypress-member-types-pro/core/field/class-bpmtp-xprofile-field-type-member-type.php on line 11

    Notice: Function is_embed was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /home/fourdegr/public_html/ccae/wp-includes/functions.php on line 5831

    Notice: Function is_search was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /home/fourdegr/public_html/ccae/wp-includes/functions.php on line 5831 `

  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #45894

    Hi Heather,
    Thank you for purchasing from us. I am very sorry for the inconvenience.

    1. Do you have BuddyPress active? I assume yes from your first line.
    2. Are you on multisite?
    3. If yes, is BuddyPress and BuddyPress Member Types Pro network active or active on some site?
    4. Do you have BuddyPress extended profile enabled (Dashboard->Settings->BuddyPress->Components)?

    Please let me know and I will assist.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Heather Dow on #45896

    Hi Brajesh,

    I didn’t have the extended profile turned on. I was able to install and activate the plugin, but it is not allowing me to add member types. When I go to that page, I just get a white spot where the controls should be.

    I have tried turning off all of my plugins, and also changing the theme. Nothing worked. I am not getting an error message on that page.

    Have you encountered this before?

  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #45897

    Hi Heather,
    Thank you for the reply.

    I am aware that the plugin may cause this error when xprofile is disabled.

    I have fixed and put a new version. Please upgrade to 1.5.0 and It will work with Xprofile disabled.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Heather Dow on #45899

    I installed the update, but it still isn’t working. Could I provide you access to a staging site so you can see what is happening?

  • Participant
    Level: Initiated
    Posts: 4
    Heather Dow on #45900
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #45901

    Hi Heather,
    Thank you.

    I am looking at it now.

    I will update you within an hour.

    Regards
    Brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #45902

    Hi Heather,
    I disabled the xprofile on your staging site and Member Types Pro seems to be working fine. Can you please check and point me to the error page.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Heather Dow on #45903

    If you go to settings and try to add member types, or go to a WooCommerce Membership level and try to add a member type, you will see that those sections aren’t operational.

  • Keymaster
    (BuddyDev Team)
    Posts: 21520
    Brajesh Singh on #45904

    Hi Heather,
    I had a look.

    You will need to create some of the member types first.

    Please visit Dashboard->Users->Member Types(pro) and add the member types.

    Once you add some, they will appear in all the sections.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved