BuddyDev

Search

[Resolved] Followers/Following Not Showing Avatars When Not Friends

  • Participant
    Level: Enlightened
    Posts: 85
    NoNAdmin on #48065

    Hello,

    I love your plugin. I’ve been using it for over 1.5 years an have hardly ever found any issues. It has made it possible to customize my site so much.

    That said, I found an issue. I created a section template and a new PROFILE tab. I inserted the “(BB) Members I’m Following” and “(BB) Members Following Me” widgets. They work correctly, EXCEPT when a user is not a “FRIEND”. The avatar of the user does not appear in the widget.

    As soon as the users become “FRIENDS”, then the avatars appear in the widgets. The total count for each widget is always correct. It is just the avatars that do not appear. Users should not need to be friends to follow or be followed.

    To ensure this was not an Elementor or BuddyBoss issue, I created an Elementor Page. I used the same section template to create the page. The widgets perform correctly on the page.

    As always, I removed all plugins that weren’t necessary, used the parent theme and had no extra CSS or code in the wp-config.php file. I am using Profile Tabs Creator Pro, version 1.2.6.

    I would be glad to send you the images that I captured and will provide credentials if you need them.

    Thank you, Dianne

  • Keymaster
    (BuddyDev Team)
    Posts: 22531
    Brajesh Singh on #48067

    Hi Dianne,
    I am sorry for the issue.
    It seems It is related to BuddyBoss as well.

    Have you tried creating an elementor section and putting that section in the sidebar of profile to test it out if it works on profile page?

    Our plugin is not aware of what kind of content is added via it. all it does is call do_shortcode on the content and rest is handled by WordPress/the plugin providing the shortcode.

    If some shortcode is not rendering correctly, that means they have some conflict/issue.

    Please try my suggestion and let me know what you found.

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 85
    NoNAdmin on #48069
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 85
    NoNAdmin on #48070

    Hello,

    I finally figured it out and only was able to figure it out because I had a sidebar with the widgets displayed. Whenever I display the My Connections Profile tab, the sidebar is incorrect, but any other Profile tab sidebar shows the correct avatars.

    Here is what I believe the problem is: I put the Profile Sub-Tab on the My Connections (Friends) Profile tab.

    I’m thinking that BuddyBoss restricts anything on that tab to Friends/Connections. I will test further and let you know.

    Best Regards, Dianne

  • Participant
    Level: Enlightened
    Posts: 85
    NoNAdmin on #48073

    Hello,

    I performed additional testing and indeed that was the issue. I resolved it by creating a separate Profile Tab and placed all the “Following” information there. It now works properly with no issues.

    Thank you for your suggestions. As always, I love your plugins and will continue to be a huge fan!

    Best Regards, Dianne

  • Keymaster
    (BuddyDev Team)
    Posts: 22531
    Brajesh Singh on #48078

    Thank you Dianne
    Yes, you are right about the connections. There are some extra things happening behind the scenes and might be causing it.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: resolved