BuddyDev

Search

[Resolved] Getting an error when trying to save Mediapress settings?

  • Participant
    Level: Initiated
    Posts: 19
    Alayna on #3438

    I just installed Mediapress and it activated just fine however when I went into the Mediapress settings to customize some settings, I clicked save and got these errors on the next screen.

    Notice: Undefined index: extensions in /Applications/MAMP/htdocs/wordpresstest/wp-content/plugins/mediapress/admin/mpp-settings-manager/core/class-mpp-admin-settings-page.php on line 510

    Warning: Cannot modify header information – headers already sent by (output started at /Applications/MAMP/htdocs/wordpresstest/wp-content/plugins/mediapress/admin/mpp-settings-manager/core/class-mpp-admin-settings-page.php:510) in /Applications/MAMP/htdocs/wordpresstest/wp-includes/pluggable.php on line 1228

    Any idea on what’s going on? I had to deactivate it to get my site working again but I’d love to use this plugin.

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #3439

    Hi Alayna,
    I am sorry for the inconvenience. Is there any chance that you network activated MediaPress?
    I don’t see any reason why there will be an error like this except there is an empty setting throwing notice somewhere.

    Enabling WP_DEBUG will give you exact issue why it happened.

    Please do let me know more details.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 19
    Alayna on #3456

    Hi Brajesh, thank you for your answer.

    I definitely did not network activate Mediapress. I tried some troubleshooting, I activated default twenty sixteen theme and deactivated all plugins except for bbPress, Buddypress and MediaPress, but saving changes still generates these errors. I have WP_DEBUG enabled but it’s only giving me the two errors I posted before.

    Notice: Undefined index: extensions in /Applications/MAMP/htdocs/wordpresstest/wp-content/plugins/mediapress/admin/mpp-settings-manager/core/class-mpp-admin-settings-page.php on line 510

    Warning: Cannot modify header information – headers already sent by (output started at /Applications/MAMP/htdocs/wordpresstest/wp-content/plugins/mediapress/admin/mpp-settings-manager/core/class-mpp-admin-settings-page.php:510) in /Applications/MAMP/htdocs/wordpresstest/wp-includes/pluggable.php on line 1228

    Really weird, I can’t seem to understand what’s going on.

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #3458

    Hi Alayna,
    Which version of WordPress, BuddyPress & MediaPress are you using? Are you on the latest version for all of these? Also, the error means that the sanitize callback stack is empty for the extensions option. I am sorry but I haven’t seen anything like this earlier.

    Do you see your extensions empty? Is there anything special about this site that you can tell me and which may help to understand the situation?

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 19
    Alayna on #3474

    I am using the latest available versions of WordPress, Buddypress & MediaPress.

    So it seems that I have solved the problem though I still don’t know exactly what it was…

    For comparison, I installed rtMedia and saw that the plugin was also functioning wrong. At this point I determined it was something wrong with my database, so I cleared my datatables everywhere and reinstalled WP but still, no improvements. Even with a fresh install, I was getting odd errors. Finally after getting fed up, I backed up my stuff and deleted my entire directory under MAMP. Installed WordPress on XAMPP and started all over, and surprise… everything is working fine. Luckily, my modifications have all been through a child theme so there was no problem with starting over.

    Really odd issue that occurred but I’m glad I sorted it out! Thank you for your diligent attention! Really excited to use the plugin.

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #3475

    Thank you Alayna,
    I am sorry for the inconvenience but glad that it is working finally.

    Have a great time building your project.

    Please feel free to ask us anything you need to know about the plugin. I am marking this topic as resolved for now.

    Thank you
    Brajesh

The topic ‘ [Resolved] Getting an error when trying to save Mediapress settings?’ is closed to new replies.

This topic is: resolved