BuddyDev

Search

Group tab not visible to members

Tagged: 

  • Participant
    Level: Initiated
    Posts: 3
    Roger Rowles on #49895

    Hello,

    I’ve set up a new group tab with two sub-tabs, one visible to members and one visible only to moderators and admins.

    If I’m logged in to my administrator account, I can see the tab. If I’m logged into my test moderator account, I can see the tab.

    If I log into my test Member account, clicking on the group tab shows a 404.

    Here is a screenshot with the group tab settings: https://www.dropbox.com/s/q3twnzgq9vhxp7v/screencapture-portal-crlanguages-wp-admin-post-php-2023-07-03-11_03_58.png?dl=0

    Am I doing something wrong? I’ve tried logging in an out, clearing the cache, and messing with a few different settings.

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2752
    Ravi on #49898

    Hello Roger,

    Sorry for the inconvenience. We consider the first subtab as the default tab and as per your screenshot, it seems that your first tab is only visible to Group admins and Moderators only that’s why when you try to access it as a group member you are getting a 404 page.

    Please replace your second tab with the first tab and the first tab as the second tab.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 3
    Roger Rowles on #49914

    Ahhh, that makes sense! Thank you!

    My goal is to have one sub nav visible to one set of users (students/members) and another sub nav visible to another set (instructors/moderators). To avoid confusion, I’d prefer that users only see their respective sub nav. Is that possible or will one set always see a 404?

    Should I use two separate tab groups instead?

    Thanks!

  • Participant
    Level: Initiated
    Posts: 3
    Roger Rowles on #49916

    I just tried setting up two different groub tabs, one for moderators and one for members. My test moderator account can see both tabs. Is there a way to have a tab only visible to members and another only visible to moderators?

    Thanks!

  • Keymaster
    (BuddyDev Team)
    Posts: 23833
    Brajesh Singh on #49917

    Hi Roger,
    Thank you for the replies.

    The problem with tab setup is “Moderators” & “Group admins” are also group members. That’s how BuddyPress/BuddyBoss treats them.

    That’s why they are seeing both the tab.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Roger Rowles on #49922

    Thant’s what I figured. Thanks for your help!

  • Keymaster
    (BuddyDev Team)
    Posts: 23833
    Brajesh Singh on #49929

    Hi Roger,
    You are welcome!

You must be logged in to reply to this topic.

This topic is: not resolved