BuddyDev

Search

hide_comments in buddypress.js not working.

  • Participant
    Level: Initiated
    Posts: 2
    Paul Marek on #23306

    Hey guys,

    My activity feed is displaying unlimited comments and nested comment threads.

    I want to hide long comment threads in the activity feed so that a user has to click “view all comments” or something like that to view them all.

    I’ve tried changing the bp_legacy_theme_hide_comments in my buddypress.js to show only 2 comments instead of the default 5 that it has there, and I’ve also tried changing it in bp_dtheme_hide_comments of the global.js file.

    I’ve tried changing this in the core buddypress code as well and it is still displaying unlimited comments.

    Any ideas what I might be doing wrong?

  • Keymaster
    (BuddyDev Team)
    Posts: 21779
    Brajesh Singh on #23309

    Hi Paul,
    Welcome to BuddyDev.

    The comments visibility may depend on which theme or template pack you are using.

    1. Which theme are you using? Is it a custom theme?
    2. Which template pack is enabled? Is it BuddyPress Legacy or BP Nouveay?

    Please let me know and I will assist.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 2
    Paul Marek on #23323

    Hey Brajesh, thx for the reply.

    The base WordPress theme we’re using is OnePress:
    https://wordpress.org/themes/onepress/

    The BuddyPress theme (actually it’s a plugin, not a theme) we are using is Youzer:
    https://youzer.kainelabs.com/
    https://codecanyon.net/item/youzer-new-wordpress-user-profiles-era/19716647

    The template pack we are using is BP Nouveau.

    Thanks and hope this helps!!

  • Keymaster
    (BuddyDev Team)
    Posts: 21779
    Brajesh Singh on #23326

    Hi Paul,
    Thank you for the details.

    Since you are using Youzer, My guess is it is most probably the reason. I have seen numerous issues with Youzer in last 2-3 months(for our plugins as well as 3rd party plugins).

    It does not honour the template pack and overrides it, that’s why your js is not taking any effect. Try disabling it to check and you will see it working.

    My suggestion will be to contact Youzer and ask them for a solution.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 2
    Paul Marek on #23327

    OK thanks.

  • Keymaster
    (BuddyDev Team)
    Posts: 21779
    Brajesh Singh on #23368

    You are welcome. Hope it gets resolved by them.

You must be logged in to reply to this topic.

This topic is: not resolved