BuddyDev

Search

[Resolved] Insecure endpoint in Activity, 'http://domain/activity/reply/


  • Participant
    Level: Guru
    Posts: 774
    calu on #35398

    Hi there, when users are posting in the what’s new textarea #buddypress form#whats-new-form textarea
    The page is not secure with SSL and this error occurs in the console.

    jquery.min.js?ver=3.5.1:2 Mixed Content: The page at 'https://domain/activity/' was loaded over a secure connection, but contains a form that targets an insecure endpoint 'http://domain/activity/reply/'. This endpoint should be made available over a secure connection.

    Is this is a core BP issue?

    Regards
    Carsten


  • Keymaster
    (BuddyDev Team)
    Posts: 17473
    Brajesh Singh on #35400

    Hi Carsten,
    Does not seem like a BuddyPress issue.

    Please check your Dashboard->Settings and make sure the WordPress address and site address have proper https in the url.

    Regards
    Brajesh


  • Participant
    Level: Guru
    Posts: 774
    calu on #35436

    Hi Brajesh, thanks for your suggestion. I’m not sure which settings you are referring to, but the site is secured with SSL encryption, except for this slug, /activity/reply/, so I can’t see there should be any missing settings. I will ask cPanel support, thanks.

    Regards
    Carsten


  • Keymaster
    (BuddyDev Team)
    Posts: 17473
    Brajesh Singh on #35447

    Hi Carsten,
    Please login to your site dasboard(WordPress) and visit the “Settings->General” tab. Are all url using https there in the form(There is a form with 2 urls)?

    Regards
    Brajesh


  • Participant
    Level: Guru
    Posts: 774
    calu on #35452

    Hi Brajesh, not in my General Settings

    https://imgur.com/QkUfoQQ

    Regards
    Carsten


  • Keymaster
    (BuddyDev Team)
    Posts: 17473
    Brajesh Singh on #35456

    Hi Carsten,
    No that one. I am referring to this one
    https://i.imgur.com/GvKeF9w.png

    Regards
    Brajesh


  • Participant
    Level: Guru
    Posts: 774
    calu on #35459

    Hi Brajesh, yes of course, you were absolutely right WordPress Address (URL) and Site Address (URL) were not changed to https.

    Thank you very much Brajesh, you saved me for a lot of time troubleshooting this issue!

    Regards
    Carsten


  • Keymaster
    (BuddyDev Team)
    Posts: 17473
    Brajesh Singh on #35507

    Hi Carsten,
    You are welcome. I am glad it is resolved.

    Regards
    Brajesh

The topic ‘ [Resolved] Insecure endpoint in Activity, 'http://domain/activity/reply/’ is closed to new replies.

This topic is: resolved
Subscribe