BuddyDev

Search

Issue with member types pro assigning all available member types to new user

  • Participant
    Level: Initiated
    Posts: 11
    Fmd530 on #39667

    Hi. I’m having an issue with Member types pro where I have 3 member types created – on signup users need to select 1 of them, but then when their user is activated the user has ALL 3 member types assigned.

    What may I provide in order to help you help me?

    Thank you for your time

  • Keymaster
    (BuddyDev Team)
    Posts: 19031
    Brajesh Singh on #39669

    Hi,
    Thank you for using our plugin.

    Please share the following details:-

    1. BuddyPress Version
    2. WordPress version
    3. Theme name and version
    4. Which template pack are you using?
    5. Member types pro version
    6. Member type Pro field type used for registration(is it single member type or multi field).

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    Fmd530 on #39685

    1. BuddyPress (Currently 9.0, but the problem was present with 7.3, I updated trying to solve it and it persisted)
    2. Worpress version 5.5.5 (Havent tried updating it)
    3. Theme: CERA 1.1.6
    4. None I think, but I’m using Youzer. Youzer version 3.1.6
    5. Member types pro 1.4.8
    6. Single member type – radio buttons

    Hope this helps!

  • Keymaster
    (BuddyDev Team)
    Posts: 19031
    Brajesh Singh on #39689

    Hi,
    Thank you for the details. I am assuming it is due to conflict with Youzer. Youzer has a different way of handling things and we do not have compatibility with it.

    I will get it tested by Monday and report back. If it is doable, we will try to add compatibility for Member Types pro.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    Fmd530 on #39750

    Thanks!

    Just to add, I do have another website where member types pro and youzer are working correctly.
    The version on this other website is

    Youzer 2.6.2
    Member types pro 1.4.6

    So yeah, could be the newer version of youzer causing the issue.
    Let me know if I can help figure it out.

    Thanks you very much!

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #39758

    Hello,

    Thank you for sharing the details. We do not have access to the latest version of the plugin “Youzer”. Please share the latest version of this plugin so that I could help you.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 11
    Fmd530 on #39802
    This reply has been marked as private.
  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 1685
    Ravi on #39804
    This reply has been marked as private.

You must be logged in to reply to this topic.

This topic is: not resolved