BuddyDev

Search

Limit login for branded login plugin

  • Participant
    Level: Guru
    Posts: 701
    Tosin on #35942

    Hello,

    You once added support for this plugin https://wordpress.org/plugins/limit-login-attempts-reloaded/ to your branded login plugin but its no longer compatible, Please can you update it again for compatibility.

    You added support for branded login in Version: 1.3.6 see changelog

    Thanks

  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #35967

    Hi Tosin,
    Thank you for reporting.

    I am requesting @ravisharma to look into it and assist you.

    Regards
    Brajesh

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2459
    Ravi on #35985

    Hello Tosin,

    Please upgrade to newer version of plugin and let me know if it works or not.

    Regards
    Ravi

  • Participant
    Level: Guru
    Posts: 701
    Tosin on #35987

    login page can’t be accessed and logins are not successful keep getting the error

    http://www.website.com redirected you too many times.
    Try clearing your cookies.
    ERR_TOO_MANY_REDIRECTS

    This error occurs without activating limit login attempts plugin

    Please note that I have this code in my functions.php

    
     /**
     * Email login support for bp-branded-login plugin
     */
    add_filter( 'wp_authenticate_user', function( $user ) {
    
    	if ( isset( $_POST['log'] ) && ! is_email( trim( $_POST['log'] ) ) ) {
    		return new WP_Error( 'invalid_email', __( 'Please provide a valid email' ) );
    	}
    
    	return $user;
    }, 10 ); 
    
  • Participant
    Level: Guru
    Posts: 701
    Tosin on #35988

    Kindly ignore above message the fault was mine I had this plugin enabled https://perfmatters.io/docs/change-wordpress-login-url/

  • Participant
    Level: Guru
    Posts: 701
    Tosin on #35989

    The plugin now works perfectly

    1. How can I change the failed login error from (Password is Invalid!) to (Email or Password is Invalid!)

    2. I have login disabled by username using the code above. When a user mistakenly tries to login with username instead of email this error message shows (Invalid Request) how can I change this to (Please login with valid email)

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2459
    Ravi on #36000

    Hello Tosin,

    1. You can use any WordPress translator plugin to replace the message.
    2. I have checked login through email and getting ‘Invalid Email’ error message. Please check:
    https://tinyurl.com/y45wjww8

    Regards
    Ravi

  • Participant
    Level: Guru
    Posts: 701
    Tosin on #36004

    Thank please can you review this code if it will work

     // Change wordpress login form text labels //
    function branded_login_change_error_text( $translated_text, $text ) {
       if ( is_page( 'login' ) ) {
    	   
       $original_text = 'Password is Invalid!';
       $new_text = 'Your Email or Password is Invalid!';
       if ( $text == $original_text ) {
          $translated_text = $new_text;
       }
       return $translated_text;
      }
    }
    add_filter( 'gettext', 'branded_login_change_error_text', 30, 3 ); 
  • Participant
    Level: Guru
    Posts: 701
    Tosin on #36009

    The second problem has been solved the difference in login error message was caused by this plugin iThemes Security at https://wordpress.org/plugins/better-wp-security/ it has a settings under (wordpress tweaks) to select login method either by

    1. Email Address and Username (Default)
    2. Email Address Only
    3. Username Only

    My previous setting option was set at Email Address Only which caused the (invalid request) error message. I changed this setting back to Email Address and Username (Default) and this solved the problem.

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2459
    Ravi on #36019

    Hello Tosin,

    Thank you for the acknowledgement. I am glad that issue is resolved. Please do let me know if you need further assistance on this topic.

    Regards

You must be logged in to reply to this topic.

This topic is: not resolved