BuddyDev

Search

MediaPress: Cannot activate the plugin


  • Participant
    Level: Initiated
    Posts: 4
    solvingissues on #24582

    Hi,

    I installed the plugin for my network and now I’m trying to activate the plugin on one of my sites. Unfortunately, it does not work. It says:
    “Plugin could not be activated because it triggered a fatal error. Fatal error: Cannot redeclare mpp_get_default_options()”

    I need help in this case.

    Bst regards!


  • Keymaster
    (BuddyDev Team)
    Posts: 12076
    Brajesh Singh on #24583

    Hi,
    Welcome to BuddyDev.

    Please visit dashboard->Network Admin->Plugins and make sure you deactivate MediaPress.
    After that, Please visit the site you want to activate it and activate.

    A network active plugins can not be activated on sub sites. MediaPress is not meant for network activation.

    Regards
    Brajesh


  • Participant
    Level: Initiated
    Posts: 4
    solvingissues on #24584

    Hi,

    Thanks for the fast reply. I did NOT activate the MediaPress Plugin in the network – network-wise it is deativated. Nevertheless, I cannot activiate it on one of my sites.

    Regards


  • Participant
    Level: Initiated
    Posts: 4
    solvingissues on #24585
    This reply has been marked as private.

  • Keymaster
    (BuddyDev Team)
    Posts: 12076
    Brajesh Singh on #24586

    Hi,
    I am sorry, It seemed from your reply that you are on multisite. Sorry for the assumption.

    1. Are you on mutltisite? May I get temporary access to check. this is not expected behaviour for MediaPress.

    Thank you
    Brajesh


  • Keymaster
    (BuddyDev Team)
    Posts: 12076
    Brajesh Singh on #24587

    Thank you. makes sense.

    It seems the plugin “Multipage” uses same function name. Can you please deactivate it temporarily and then activate MediaPress.

    Regards
    Brajesh


  • Participant
    Level: Initiated
    Posts: 4
    solvingissues on #24605

    Hey,

    I deactivated “Multipage”, activated “MediapPress” (it worked) and tried to activate “Multipage” againg – this did not work (as expected): “Fatal error: Cannot declare class MPP_Admin, because the name is already in use”

    Best regards!


  • Keymaster
    (BuddyDev Team)
    Posts: 12076
    Brajesh Singh on #24608

    Hi,
    Thank you for the reply.

    I had a look at the plugin. It seems Our plugin and Multipage has common names for some classes/functions.

    That is leading to this conflict. I am sorry but in this case only one of them can be used.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved
Subscribe