BuddyDev

Search

Mediapress – Images published on activity feed not available

  • Participant
    Level: Initiated
    Posts: 11
    jasmina on #52271

    When someone uploads an image via the personal activity feed, nothing appears in the main activity feed when they are a logged-in member of my site. Only updates to the image gallery or the publication of new blog posts appear in the main activity stream.
    The default gallery/media status in the privacy settings is set to Public. Can you please help me?

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #52272

    Hi Jasmina,
    Welcome to Buddydev support forums.

    Which theme and template pack are you using? Is there any chance that you are using a plugin like Youzer or elementor/activity shortcodes for showing the stream?

    Please share the details and we will assist.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    jasmina on #52295

    Hello Brajesh,
    Thanks !
    I use a theme called SocialV. It uses BuddyPress and MediaPress to manage users and publish content in the news feed. I don’t use the Youzer plugin, on the other hand, I have Elementor on my site, but I don’t use it to manage the news feed, it was already set up by Buddypress.

    Additional information: the description of my publication appears, but not the image. What’s more, the image of my publication appears in the MediaPress > Wall Photo Gallery list.

    In another private reply, i will send you the content of MediaPress Debug Tool.

    Thanks for your help !

  • Participant
    Level: Initiated
    Posts: 11
    jasmina on #52296
    This reply has been marked as private.
  • Participant
    Level: Initiated
    Posts: 11
    jasmina on #52313

    Hello,
    I would like to know if someone can help me solve this problem please.
    Thanks in advance

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #52318

    Hi,
    I am sorry for the delayed reply.
    It seems the problem is related to media privacy. Your media’s default privacy is set to friends only. Please set the default privacy to public to allow the media to appear in the main activity feed.

    You can do it from Dashboard->MediaPress->settings->General screen (It is under Privacy Settings section)

    Once you have set it, Please upload a new media and test as the setting will only apply on new uploads. Please let me know if that works or not?

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    jasmina on #52321

    Hello,

    No problem for the deadline, it’s just that it’s a customer’s project and I’m in charge of production.

    So I made the modification you recommended, but I did a test and nothing changes, the image is still not visible.

    Sincerely
    Jasmina

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #52322

    Hi Jasmina,
    Thank you. We will be assisting you better onwards.

    Can you please check if the wall gallery is marked as private/friendsonly for the user you posted? The wall galleries are public by default(on your setup, every media/gallery had default status of friendsonly).

    If yes, Please edit the gallery and change privacy to “Public” and then please upload again.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    jasmina on #52381

    Hello,
    Sorry I’m a bit late replying!
    I have modified the following information as follows:

    // MediaPress Settings //
    active_components: sitewide,members
    default_status: public
    active_statuses: public
    active_types: photo,video,audio

    I did a test and nothing changes, the image is still not visible.

    Thank you
    Jasmina

  • Keymaster
    (BuddyDev Team)
    Posts: 24262
    Brajesh Singh on #52391

    Hi Jasmina,
    Thank you for the reply.

    Please ensure that your wall gallery is marked public too. I believe, you haven’t updated that(from your profile->Gallery->Wall Gallery->Edit)

    Let me know if you have already done that too?

    Thank you
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved