BuddyDev

Search

[Resolved] MediaPress logged-in permissions block image display in activity

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #23090

    hi Brajesh,

    a sneaky permissions/display issue has cropped up on my site.

    A user specifies “logged-in-users-only” as the permissions settings for a gallery, and expects the main site activity feed (for logged in users) to display his image. The image never appears in the main activity feed, although the image appears on the users feed.

    Exactly the same behaviour is observed in public groups. If the gallery is also set to “public”, the image is displayed everywhere as expected. As soon as “logged-in-users-only” is used for the gallery, the images disappear from the main activity feed view, and appear only in the group activity feed.

    Have you come across this before, and/or do you know how we can fix this?

    R.

  • Keymaster
    (BuddyDev Team)
    Posts: 21769
    Brajesh Singh on #23091

    Hi Richard,
    In BuddyPress, The activity can have only 2 states.
    Either public or hidden(private).

    That’s why it is happening so. Unless BuddyPress adds more level, we are unable to do anything about it.

    Regards
    Brajesh

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #23094

    hi Brajesh,

    ok, that’s a bit clunky (of buddyPress), and highly non-intuitive, but is certainly out of your hands.

    Many thanks for the clear explanation.

    R.

You must be logged in to reply to this topic.

This topic is: resolved