BuddyDev

Search

Mediapress Members gallery page not working

  • Participant
    Level: Master
    Posts: 163
    Audiomonk on #22238

    I’m just getting a series of … instead?

    I can see the individual galleries in the admin menu, and members can see their own etc. Just that page doesnt’ seem to be working. It’s not viewable

    Edit Note: Log Information Removed.

    • This topic was modified 2 years, 8 months ago by Brajesh Singh. Reason: removed Log
  • Keymaster
    (BuddyDev Team)
    Posts: 19859
    Brajesh Singh on #22245

    Hi Audiomonk,
    I am sorry for the issue. I am unable to understand it though.

    Please share some screenshots to show the issue and help me assist you better.

    Thank you
    Brajesh

  • Participant
    Level: Master
    Posts: 163
    Audiomonk on #22254

    https://pasteboard.co/I9PGCBf.png

    The member galleries can obly be seen by logged in members, but when logged in, everyone (including administrators gets the following page)

    https://pasteboard.co/I9PGCBf.png

  • Participant
    Level: Master
    Posts: 163
    Audiomonk on #22255

    I should point out, that all the galleries are there, and that members own galleries on their profile all work correctly. It’s just that page.

    I tried creating a different page with the shortcode, but the same result, just three dots.

  • Participant
    Level: Master
    Posts: 163
    Audiomonk on #22258
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19859
    Brajesh Singh on #22269
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 19859
    Brajesh Singh on #22270

    Hi Audiomonk,
    I am assuming that screenshot is for gallery directory? Have you created it using shortcode? If yes, what is the shortcode?

    Thank you
    Brajesh

  • Participant
    Level: Master
    Posts: 163
    Audiomonk on #22278

    Hi Brajesh,

    The page didn’t have a shortcode, as far as I can remember it was a page set up when either Mediapress or Buddypress was set up. The shortcode I tried later was

    [mpp-list-gallery]

    Then I tried other shortcodes, and other shortcodes aren’t working either. As a user you can see your own galleries by clicking on profile menu items, but it seems as if the shortcode part is broken.

    (Thank you for marking as private)

  • Keymaster
    (BuddyDev Team)
    Posts: 19859
    Brajesh Singh on #22282

    Hi Audiomonk,
    Thank you for the details.

    The page does not seem to be created by MediaPress. We create only 1 page(Gallery directory).

    Please visit Settings->BuddyPress->Pages and see if a page is assigned to “Gallery”. This page is our directory.

    MediaPress does not use any other page.

    The shortcode did not work for you as the default status for shortcode is ‘public’. You may add status=’public,loggedin’ to list all galleries with logged in status as well as include any public gallery.

    Regards
    Brajesh

  • Participant
    Level: Master
    Posts: 163
    Audiomonk on #22643

    Hi Brajesh,

    It’s been a while, I was caught up in other work.

    The settings/buddypress/pages has the gallery set to a page called Member Galleries, which was a page set up originally for the galleries, and that has worked for a long time. So not sure why it isn’t working now.

    The shortcode advice worked, and I can now create a separate page to display them all so this might be a way round it, it’s not showing the authors of the galleries though. It’s been that long since we looked at that, I can’t even remember how it was before. I guess something must have been overwritten in an upgrade or something.

    Thanks for your help Brajesh.

You must be logged in to reply to this topic.

This topic is: not resolved