Get 15% off on all our plugins, themes and memberships till 4th December. Use coupon: BLACKFRIDAY2021.

BuddyDev

Search

[Resolved] MediaPress on multisite issue

  • Participant
    Level: Enlightened
    Posts: 56
    Andy on #1588

    I would like to use this plugin on my BuddyPress site, but I have an issue.

    This plugin works great on a non multisite WordPress install. But on a WordPress multisite, it is only working correctly for the super admin, any other user gets the following message when they try to upload media:
    “This file type is not allowed in current gallery. Only files are allowed!”

    someone else posted this here https://github.com/buddydev/mediapress/issues/1

    I always have up to date WordPress and BuddyPress versions, and I followed the instructions of saving the settings before use. I prefer Buddypress network activated, and activate mediapress on my main site, however, it still doesn’t work if I activate Buddypress on my main site.

    I just tested this as basic as possible with a fresh installation of WordPress, removed all plugins and used a basic theme. I set up WordPress multisite. I activated mediapress and buddypress on the main site (not network activated). And saved the mediapress settings. So the super admin can upload images, but any user that registers can’t, they get that error message when they upload media. So this is only an issue with a WordPress multisite. Do you know what the problem could be?

    I hope this can be fixed as I really like this plugin.

  • Keymaster
    (BuddyDev Team)
    Posts: 19833
    Brajesh Singh on #1589

    Hi Andy,
    Welcome to BuddyDev forums.
    My apologies for the inconvenience.

    I am sorry that I was not able to reproduce it earlier ( was testing gallery by enabling on sub sites which worked).

    yes, There was a problem with uploads when a user was not part of(member of ) the main site/site where the MediaPress was active.

    The reason was WordPress does not update taxonomies if the user is not part of the site.

    I have updated the plugin and pushed the updates to github. Please upgrade and check again.

    It should be fixed.

    PS: The best way to use MediaPress on Multisite is to enable it on the sites you need. Each site has its own instance of MediaPress.

    Please let me know if that works for you or not.

    PS: Please delete the users wall gallery( who was not able to upload) from MediaPress->All Galleries screen. Otherwise a new wall gallery will not be created for him and the problem will remain there.

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 56
    Andy on #1601

    Hi Brajesh.

    Wow, that was fast. Yes that has fixed the problem. I’m delighted this issue has been resolved because this plugin is the best. I will definitely be recommending this plugin to other BuddyPress users.

    Thank you.

  • Keymaster
    (BuddyDev Team)
    Posts: 19833
    Brajesh Singh on #1604

    Thank you Andy 🙂

The topic ‘ [Resolved] MediaPress on multisite issue’ is closed to new replies.

This topic is: resolved