BuddyDev

Search

[Resolved] MediaPress photos should Inherit gallery permissions

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #13109

    hi Brajesh,

    the standard wp_post attachment behaviour is, I think, for the media to inherit visibility from the parent_post / gallery. This does not seem to carry across fully under MediaPress. What I mean is this:

    If the gallery is set to public, the photo should default to public too, yes? Equally, if the gallery is set to logged-in or friends, then the photo should default to the same. Right.

    Currently, what seems to happen is that regardless of what the gallery privacy is set to, the photo takes the default defined in the admin settings. Wrong.

    Does this make sense?

    Cheers

    R.

  • Participant
    Level: Master
    Posts: 279
    Richard Foley on #13110

    I’ll explain: what happens on my site, is that a user defines a gallery as for friendsonly, and then uploads several images from the activity feed. He quite reasonably expects the photos to be visible to friends only. However, the media gets uploaded as public, and he doesn’t notice this from the feed.

    Not a good situation. If you need several types of behaviour (inherit/not) then I’d suggest this be a configurable option.

    ps. I can’t edit my post, so I have to reply here.

  • Keymaster
    (BuddyDev Team)
    Posts: 21292
    Brajesh Singh on #13113

    Hi Richard,
    The media inherits the privacy of parent gallery unless you specify the privacy manually.

    Please see
    https://github.com/buddydev/mediapress/blob/master/core/ajax/mpp-ajax.php#L289

    Line 289-299.

    We use any custom privacy if given with the request, otherwise we use gallery privacy and if that is also not available, we use the default specified in the admin.

    I am not sure what is happening on your install but your expectations are correct and that is exactly how we are handling it.

    If there is any other information, Please do let me know.

    Thank you
    Brajesh

You must be logged in to reply to this topic.

This topic is: resolved