BuddyDev

Search

[Resolved] member types pro

  • Participant
    Level: Enlightened
    Posts: 130
    giuseppe on #43912

    Hello,
    I have installed Member types pro with the aim to have two different set of fields on registration form.

    I have followed your 3 videos and I have added two member types, created fields and set them for the two member types.

    I don’t need to create pages or directory where listing the member of the two types so I have set options only to have fields on the registration page (I’m not sure if it’s correct).

    On the registration page only “name” (without ser for types) is visible among all the fields.

    Where the settings is wrong to have this?

    Many thanks,

    Giuseppe

  • Participant
    Level: Enlightened
    Posts: 130
    giuseppe on #43913
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 22212
    Brajesh Singh on #43940

    Hi Giuseppe

    In order for a field to be available to registering members, Please make sure it is marked as available to users without any member type too.

    Please also add a member type field to allow users select the member type.

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 130
    giuseppe on #43941
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 22212
    Brajesh Singh on #43953
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 130
    giuseppe on #43984
    This reply has been marked as private.
  • Participant
    Level: Enlightened
    Posts: 130
    giuseppe on #44020

    Hello,

    have you taken a look for understanding?

    Thank you very much,

    Giuseppe

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 2499
    Ravi on #44022

    Hello Giuseppe,

    Thank you for sharing the details. We will check and will acknowledge you soon.

    Regards
    Ravi

  • Keymaster
    (BuddyDev Team)
    Posts: 22212
    Brajesh Singh on #44049

    Hi Giuseppe,
    Thank you for the patience.
    The issue was the theme. It was not updated for BuddyPress 9.0+ and was not fetching the signup fields.

    I updated your registration template and it is fetching the fields correctly. Please update the fields there as you need by updating their availability to specific member type(in the Dashboard->Users->Profile Fields).

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 130
    giuseppe on #44068

    Hi,
    thank you very much for your unvaluable support.

    Only this issue: when the plugin is activated the Xfields disappear from the header of the member:

    activated: https://ibb.co/qWCkT5V
    deactivated: https://ibb.co/cwDzqkx

    How could we fix this?

    Many thanks,

    Giuseppe

You must be logged in to reply to this topic.

This topic is: resolved