BuddyDev

Search

Membertypes Pro Loop Conflict

  • Participant
    Dwi Guna on #10153

    Hello Brajesh,

    I need your help regarding a plugin conflict with philopress plugin “buddyblock”.

    I already contact Shane from Philopress before and he said His buddyblock plugins has no issue with Buddydev Member Types Generator Plugin

    But he suggest that it has conflict wit Loop in Buddydev Member Types Pro. So he suggest me to contact you here to start a communication

    =====
    The situation is like this:
    I purchased buddyblock and have done some setting on it. Include the
    visibility option in Member Directory

    But I found strange behaviour. Let say I have a total of 5 members and
    2 member types (premium 2 user and gold member type 1 user and 2 user without
    member types). Me as Admin is gold user

    When I hide premium user member type. In directory members “all
    members” it become 3 members only (this is correct)

    When I hit premium tab, It also give 3 members as I see in All members
    (this is wrong, it is supposed to be empty)

    When I hit gold type, It also give 3 members as I see in All members
    (this is wrong, it is supposed to be 1 member, me)
    =====

    Shane from Philopress said that it is a loop problems, and I should contact you (Brajesh). And he also said that you can ask him anything related to this issue

    Thanks and Best Regards
    Dwi

  • Keymaster
    (BuddyDev Team)
    Posts: 22175
    Brajesh Singh on #10157

    Hi Dwi,
    I am sorry for the inconvenience.

    Can you please ask Shane if he is filtering on “bp_after_has_members_parse_args”

    We are filtering on it for 2 case:-

    1. When you setup some member type to be excluded, we filter to add member_type__not_in and include parameters
    2. When clicking on member type name, It is again filtered to have only specific member type.

    Can you please post me the code used for directory filtering.
    Also, can you please try by disabling the buddyblock and see if it working correctly?

    I am not sure where the issue lies yet(bpmtp or the buddyblock), Please let me know the details and I will assist you to resolve it.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved