BuddyDev

Search

posts are not shown in post list (e.g. published)

  • Participant
    Level: Initiated
    Posts: 3
    Franz on #49296

    Hi there,

    unfortunately the new user posts and some of the already available posts of that ser are not shown in the post list. My user has 21 posts and only some nine posts are listed. Pages two and three are empty.

    What might be wrong?

  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 3012
    Ravi on #49297

    Hello Franz,

    Sorry for the inconvenience. I am assuming you are using the BuddyBlog Pro plugin. Please navigate to Admin Dashboard > BuddyBlog > Settings > Post ( your post type ) > Misc Settings and locate “Should tab post lists show only the posts created by BuddyBlog(front end)?”. please set it to No and then recheck.

    Please let me know if it helps or not.

    Regards
    Ravi

  • Participant
    Level: Initiated
    Posts: 3
    Franz on #49300

    Unfortunately this does not resolve the issue.
    I think there is a problem with database?

    yes, I use Pro version.

    Best regards,
    Franz

  • Keymaster
    (BuddyDev Team)
    Posts: 24308
    Brajesh Singh on #49301

    Hi Franz,
    Thank you for the details.
    is there any chance you are viewing a user profile as the user themselves or as admin?
    In these 2 use cases, the count shows all posts of the user except the posts with status ‘auto-draft’.

    There are 2 possible reasons of the issue:-

    1. Do you have taxonomy include/exclude enabled for the BuddyBlog post form. The count ignores this and includes all posts form the post type by the author.

    2. or, Do you have any plugin or code that works with post loop. If a plugin/code modifies args for WP_Query without checking properly, It can affect our list.

    If you have a staging site, Please try keeping BuddyBlog pro and BuddyPress/BuddyBoss platform enabled and disable all other plugins/custom codes. Does it still happen?

    If not, then please try activating code/plugins one by one and let us know the conflicting plugin.

    PS:- Are you using BudyBlog Groups too? At the moment, the count is incorrectly including posts from BuddyBlog Groups too.

    Please let me know your findings.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 3
    Franz on #49302
    This reply has been marked as private.
  • Participant
    Level: Initiated
    Posts: 3
    Franz on #49303
    This reply has been marked as private.
  • Keymaster
    Level: Yogi
    (BuddyDev Team)
    Posts: 3012
    Ravi on #49304
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 24308
    Brajesh Singh on #49308

    Hi Franz,
    Thank you for your patience.
    The pagination was a bug in BuddyBlog Pro. It happens when the sub tab needs pagination but the tab action is different sub tab slug.
    I have fixed it on your site. I will release an update for our members sometimes this week.

    Please check the site and let me know if pagination is fixed or not?

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 1
    Franz Wenzel on #49315

    Hi Brajesh,
    Yes it Worksheet, but why is the first post (Text is „Consulting Unit“) in another format than second post (Text is „Individualität in einer standardisierten Welt“)?
    Can you change that?
    Thank you
    Franz

  • Keymaster
    (BuddyDev Team)
    Posts: 24308
    Brajesh Singh on #49316

    Hi Franz,
    Thank you for confirming.

    The issue with first post is it seems It is a post created using Elementor. The the_excerpt() is not showing all the content as elementor trims it.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved