Get 15% off on all our plugins, themes and memberships till 4th December. Use coupon: BLACKFRIDAY2021.

BuddyDev

Search

[Resolved] Shortcode “Not Allowed”

  • Participant
    Level: Initiated
    Posts: 4
    Bob on #41723

    This is the code provided by BuddyBlog

    [bbl-create-by-post-type post_type='post']

    I purchased the BuddyDev Max package yesterday, looks good, no issues until I created a Buddyblog form and tried using a new blank page created with Elementor Pro. I added the shortcode widget and pasted the above shortcode into it and received a “Not Allowed” message. All software is up to date. The forms work fine when using the forms through Buddyblog.

  • Keymaster
    (BuddyDev Team)
    Posts: 19762
    Brajesh Singh on #41724

    Hi Bob,
    Welcome to BuddyDev support forums.
    Thank you for purchasing the membership.

    in order to use shortcode, Please visit Dashboard->BuddyBlog->Settings and click on the “Post” tab.

    In the create section, Please select the page and save. Now, the page can be used for creating posts.

    Please let me know if it works or not?

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Bob on #41726

    Hi Brajesh

    It does not work. I created another new page and whether I use Elementor Pro with any theme setting or a blank Gutenberg page, the shortcode widget and the provided Buddyblog code gives the Not Allowed error.

    Bob

  • Keymaster
    (BuddyDev Team)
    Posts: 19762
    Brajesh Singh on #41727

    Hi Bob,
    If you have done the above step(Page selection in the Posts tab ) and used the shortcode on the same page, Please visit that setting again and check which user roles are allowed to create the post. Is it set for the role you are checking with.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Bob on #41730

    That’s the one! Thanks Brajesh.
    No about that wait time, almost 3 minutes to respond to my first message.

    All kidding aside Brajesh, you rock.

    Thanks again for the sudden response, so appreciated

    Bob

  • Keymaster
    (BuddyDev Team)
    Posts: 19762
    Brajesh Singh on #41731

    Hi Bob,
    Thank you 🙂

    I am glad it is resolved.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: resolved