BuddyDev

Search

Sorry, you are not allowed to upload here.

Tagged: 

  • Participant
    Level: Initiated
    Posts: 4
    Martin Janos on #45976

    Hi

    I wanted to create gallery where any user can upload and see the files.

    Upload is enabled in settings and also in particular gallery. When I login as other user in incognito window, uploader is gone with message “Sorry, you are not allowed to upload here.”

    Is it even possible to create public gallery where anyone can upload and see files?

    I tried these shortcodes:
    [mpp-uploader gallery_id=3406 component=”sitewide”]

    [mpp-uploader gallery_id=3406]
    [mpp-uploader component=”sitewide”]
    Nonen seems to allwo user to upload

    Only [mpp-uploader] shows the uploader but no gallery.

    Thank you

  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #45981

    Hi Martin,
    Thank you for using MediaPress.

    Please download this addon.
    https://github.com/mediapress/mpp-global-shared-gallery

    and install/activate it.

    After that, Please mark the gallery as Globally shared in the admin edit gallery page. After that, any member of your site can upload to the gallery.

    Please let me know if it works for you or not?

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Martin Janos on #46012

    Hi Brajesh,

    Thank you for getting back to me.

    I have this plugin installed already but still it didn’t work. I had to change can_upload to true and comment condition as below:

    // the user must be able to upload to current component or gallery.
    $can_upload = true;

    /*if ( mpp_user_can_upload( $atts[‘component’], $atts[‘component_id’], $atts[‘gallery_id’] ) ) {
    $can_upload = true;
    }

    if ( ! $can_upload && $atts[‘show_error’] ) {
    return __( ‘Sorry, you are not allowed to upload here.’, ‘mediapress’ );
    }*/

    mediapress/core/shortcodes/mpp-shortcode-media-uploader.php

    Only now it’s working

    • This reply was modified 1 month, 2 weeks ago by Martin Janos.
  • Keymaster
    (BuddyDev Team)
    Posts: 21806
    Brajesh Singh on #46028

    Hi Martin,
    Thank you for the reply.

    Please remove the changes you have made(or use a fresh copy) and after activating the plugin, please make sure you have ticked the Shared gallery option as shown below.

    https://ibb.co/b7fqxS0

    That will make sure that users are able to upload.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 4
    Martin Janos on #46031

    Hi Brajesh,

    As I mentioned, this didn’t work. This was my initial approach. I installed the Globally shared gallery plugin, created gallery and checked “Allow everyone to upload”, the result was that the output was “Sorry, you are not allowed to upload here.” message instead of uploader. I got stuck on that for like 5 hours, tried different settings etc. Editing the code was the only think that made it work.

    Regards,
    Martin

You must be logged in to reply to this topic.

This topic is: not resolved