BuddyDev

Search

TRANSLATION

  • Profile photo of nana
    Participant
    Enlightened
    Posts: 104
    nana on #7344

    Hello friends!

    I want to do translation of community builder with “LOCO translate”, but tell me this:

    ——–

    “Template missing

    This bundle doesn’t define a translations template file.

    Loco can sync directly with the source code, but this can be slow if there are many files.

    Create template // Skip template // About templates”

    ———

    What should I do?
    And…Should I do it in community builder child?

    Thank you

  • Profile photo of Brajesh Singh
    Keymaster
    Yogi
    Posts: 3740
    Brajesh Singh on #7345

    Hi Celia,
    Please see this
    https://wordpress.org/plugins/loco-translate/installation/

    The translation template it is complaining is needed by loco template and is not the standard way of doing it. We recommend using poedit instead.

    https://poedit.net/

    In case you still want to use Loco, please see the second section of the Loco installation for creating the template. We do not plan to include a loco specific language template bundled unless we get at least 20 votes for the same.

    We will be happy to create and put the loco specific templates on github for download though.

    Regards
    Brajesh

  • Profile photo of nana
    Participant
    Enlightened
    Posts: 104
    nana on #7349

    Ok, I’m going to try to use POEDIT.
    I do not know how it works but maybe it’s better as you say.

    Thanks!

  • Profile photo of Brajesh Singh
    Keymaster
    Yogi
    Posts: 3740
    Brajesh Singh on #7352

    Hi Celia,
    Poedit allows us to do offline translation and is the norm in the community.

    Locoedit seems good but we do not want to bloat theme distribution because of it, unless we see adequate requirements for it.

    If you face any issue with poedit, please do let me know.

    Regards
    Brajesh

  • Profile photo of nana
    Participant
    Enlightened
    Posts: 104
    nana on #7353

    OK thanks.

    I was using LOCOtranslate for wp adverts!

    Thanks for your advice, I’ll use poedit if you think it’s for the best. 😉

You must be logged in to reply to this topic.

This topic is: not resolved