BuddyDev

Search

Users appear in Members Directory but not in the list of users in the Dashboard?

  • Participant
    Level: Guru
    Posts: 995
    calu on #34316

    Hi there, I have this strange issue with ghost users, or orphan users, who appear in Members Directory, but are not in the list of users in the Dashboard.

    The users have been deleted some time ago, and now suddenly appears in the Members Directory.
    The users can be blocked and reported, and appears in the Moderation Queue, and acts as suspended, but the list of suspended users is empty.

    https://imgur.com/VD8EJ1V

    Any idea what is going on here, why can this happen, and how do I delete these orphan users?

    Regards
    Carsten

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #34335

    Hi Carsten,
    That’s strange.

    is there any chance you are on a multisite? In case of multisite, the user should be deleted from Network Admin->Users screen.

    If not, Please check wp_users table and see if the deleted users are present or not? They should not be there.
    If they are, something is disabling complete deletion of users.

    Regards
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #34336

    Hi Brajesh, no, I’m not on a multisite.

    I have been looking after the wp_users table in File Manager in cPanel, but no luck, where do I find that table?

    Regards
    Carsten

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #34337

    Hi Carsten,
    Thank you for the reply.

    Please visit Cpanel and search for phpmyadmin, open it and you will have access to database. The tables are listed there.

    Please do not delete anything from there just check for the users.

    Regards
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #34341

    Hi Brajesh, yes, the table contains lots of users, which supposed to be deleted

    Regards
    Carsten

  • Participant
    Level: Guru
    Posts: 995
    calu on #34342

    There are users on different servers, I’m still in a sandbox environment, so I have asked my host to delete the other databases.

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #34344

    I am sorry but I am not sure of your reply.

    If the users are still there in database, It means they were not deleted completely. I will suggest disabling all plugins and trying to find out the culprit if any.

    Regards
    Brajesh

  • Participant
    Level: Guru
    Posts: 995
    calu on #34348

    I have three different WP and BP installations on three servers, for some reason, and it seems like the users are spreaded over the three installations

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #34357

    Hi Carsten,
    Thank you for the clarification.

    I hope it all gets resolved by your host or you have better idea on what was causing the issue(if it persists).

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved