BuddyDev

Search

Videos showing up as link in stead of a video thumbnail.

  • Participant
    Level: Initiated
    Posts: 10
    Bjorn on #14592

    Hello,

    When users post a video to their gallery it shows as a link instead of a video thumbnail. It seems to happen only with users on mobile devices. I’m using BuddyPress for profiles.

    Is there a way to change this?

    Best regards

    Bjorn

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #14603

    Hi Bjorn,
    is there a chance that the video is non h.264 encoded? The player(MediaElement player that comes bundled with WordPress) is only capable of playing h.264 encoded video.

    Can you please check if the videos appearing as link have anything in common(created by mobile or file format etc)?

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 10
    Bjorn on #14631

    I’m not sure. If I upload a video from my iPhone is it not h.264 encoded?

    Example: https://futurefootballprofs.nl/wp-content/uploads/mediapress/members/39/949/54574267450__E644366B-25DE-46DF-B7D9-8F8C6301DADD.mov

    Regards

    Bjorn

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #14666

    Hi Bjorn,
    It’s is the mov file. It needs conversion/transcoding. That will work when we have our transcoder available like discussed in previous topic.

  • Participant
    Level: Initiated
    Posts: 10
    Bjorn on #14735

    Okay is there anything I can do about this? Waiting a few months is not an option for me…

    Regards Bjorn

  • Participant
    Level: Initiated
    Posts: 10
    Bjorn on #15943

    Hello! Any update on this?

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #15946

    Hi Bjorn,
    I am sorry to keep you waiting on this. Till last week, I was involved in a major update to MediaPress and could not work on this.

    Right now, I am on it. It is getting a bit beyond my expectation(Multi tenant app, php client, go server, work queues, API, and encoding etc). I will need a few more days. I am not sure but I am hoping to put the first version in next 15 days.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 10
    Bjorn on #17413

    Hello Brajesh,

    Is there any progress on this subject? I would be really happy if .mov files could be shown embedded.

    Regards

    Bjorn

  • Keymaster
    (BuddyDev Team)
    Posts: 21763
    Brajesh Singh on #17414

    Hi Bjorn,
    The transcoder is available freely now.

    Please see this for the details.

    https://buddydev.com/support/forums/topic/mov-format-video-not-playing/page/4/#post-17063

    At the moment, It will allow the future uploads to be processed. I will need some time before I can allow older files to be queued and processed.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved