BuddyDev

Search

Buddypress activity comments not showing

  • Participant
    Level: Enlightened
    Posts: 29
    Kreatsya on #17953

    Hello!

    Here’s a strange thing I’m experiencing – I (or any user) posts a bp activity update, it goes well, then another user comments on it. Immediately after the reply is made it says that the original activity update has 1 comment and the comment is shown properly. When I refresh the page, the comment/reply is gone and the original activity comment count says 0. I’m using your notification widget and the user that received the comment gets the notification but when they click on it, no comment is shown and the notification box is empty.

    I tried deactivating plugins one by one to get to the one that might be causing the problem and here’s something that bugs me – no matter which plugin I deactivate, immediately after deactivation after I refresh the page, the comment and the comment count are in order. When I try to write another reply, the same thing happens, it disappears, the user gets the notification, the notification box is empty and then if I activate the same plugin again, the comments are shown again etc. I didn’t find the connection with emptying the cache, though, because nothing special would happen if I emptied the cache.

    I also tried disabling and enabling comments in bp and the same thing happened – when I disabled the option I could write that one comment and it would show (how if it’s disabled??) then the next one wouldn’t work, then I enabled it again and the same thing happened again.

    When I go to my profile, though, the reply I made to the activity update is there and when I click “view conversation’ it leads me to that person’s profile where the reply is not shown and the profile tabs are also missing.

    Do you have any idea what might be causing this?

    Thanks in advance

  • Keymaster
    (BuddyDev Team)
    Posts: 21852
    Brajesh Singh on #17972

    Hi Kreatsya,
    Do you have any caching plugin enabled? if yes, Please purge the cache and disable it and check again.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved