BuddyDev

Search

DISCUSSION "comment" SETTINGS 'saved changes are not taking effect at all'

  • Participant
    Level: Master
    Posts: 285
    evillizard on #26950

    Hello boss

    About the circled area in this screenshot: https://postimg.cc/4HvcbnDk

    On the wordpress dashboard

    Go to => settings => Discussions => “Other comment settings”.

    Uncheck all boxes or change anything… And then save

    You see that saved changes DO NOT take effect… i.e unchecked boxes still remains checked


    Its like this on all my wordpress sites…is this a major wordpress problem?… Ive tried two themes, including default twenty-nineteen theme….same thing.

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #26954

    Hi,
    Thank you for the question.

    You most probably have a caching issue. Are you suing some caching plugin that caches database queries?

    Regards
    Brajesh

  • Participant
    Level: Master
    Posts: 285
    evillizard on #26958

    I tried deactivating all plugin
    ..

    Then went back to uncheck the box that says: “comment author must fill out name and email”

    When i hit “save”

    The box still remain checked

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #26959

    Contact your host. WordPress does not have the issue in core. I am expecting it to be a caching issue.

  • Participant
    Level: Master
    Posts: 285
    evillizard on #26961

    But Is there any plugin that clears cache for all plugins?..or even the entire site…

    That you may want to suggest??

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #26962

    Since you are not using caching yourself, there is not uch I can suggest.

    Regards
    Brajesh

  • Participant
    Level: Master
    Posts: 285
    evillizard on #27026

    Yes sir,

    After a long investigation, i have ascertained once again.. That this too is a problem from my host.

    Jst like this problem i had back then:
    https://buddydev.com/support/forums/topic/other-way-to-change-translate-profile-field-name-and-description/


    You taught me how to go to the “PHP myADMIN database”

    To edit the fields

    ….
    ….

    I wonder if the same is possible for this case? … Can i edit the “discussion” settings from the
    “PHP myADMIN database” ??

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #27037

    Hi,
    It is not a good idea to change it directly in the database. You should most probably consider moving host.

    still, you can the following sql inside phpmyadmin(assuming you have selected your current database)

    
    
    SELECT * FROM wp_options WHERE option_name LIKE 'comment_%'
    
    

    Please change ‘wp_’ with your actual table prefix.

    It will list all the discussion specific settings and allow you modify there.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved