BuddyDev

Search

Gallery on custom post type pages problem

  • Participant
    Level: Initiated
    Posts: 15
    Obourgeois on #7017

    I generate a Mediapress gallery with 4 pictures and copy the snippet, something like [mpp-show-gallery id=1276]
    I paste that in the a Custom Post type page.
    When i see the page, i see my 4 pictures but when i click on it, it open a gallery page with all other galleries instead of opening only the clicked image in a box !

    Using Buddypress – Theme Woffice – Paid membership pro – …
    Any idea ?

    Best regards
    Olivier

  • Keymaster
    (BuddyDev Team)
    Posts: 21503
    Brajesh Singh on #7019

    Hi Olivier,
    I am sorry for the inconvenience.

    Can you please link me to the page? I am not sure why the permalinks are not working in this case. Can you please visit the Dashboard->MediaPress->All Galleries and see if the privacy, component, type is set properly for this gallery?

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 15
    Obourgeois on #7033
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21503
    Brajesh Singh on #7043

    Hi Olivier,
    Thank you.
    I checked it on the site and I see the issue with display. Please provide me temporary admin access to check a few more things(settings/active plugins etc).

    I will be happy to assist.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 15
    Obourgeois on #7048
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21503
    Brajesh Singh on #7074

    Hi Olivier,
    Thank you.
    It should be fixed now.

    The problem was conflict of the sitewide gallery permalink slug and the gallery directory slug.

    The Sitewide Gallery permalink slug was set to “gallery”. Also, The gallery directory page you created also had the same slug “gallery”

    I have changed the sitewide gallery permalink slug top ‘site-gallery’ and it is working now.

    PS: If you plan to change the slug again, please make sure to flush the pemalinks to avoid 404 issue.

    Hope that helps.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 15
    Obourgeois on #7081
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21503
    Brajesh Singh on #7096
    This reply has been marked as private.
  • Participant
    Level: Initiated
    Posts: 15
    Obourgeois on #7141
    This reply has been marked as private.

You must be logged in to reply to this topic.

This topic is: not resolved