BuddyDev

Search

[Resolved] HTML in media descriptions

  • Participant
    Level: Initiated
    Posts: 11
    Kristin on #9149

    When a user adds a description to a photo or other media in their gallery, then clicks “Save”, the html becomes visible in the description text box (while still on the edit page). Is there any way to prevent this from happening?

  • Keymaster
    (BuddyDev Team)
    Posts: 22211
    Brajesh Singh on #9152

    Hi Kristin,
    Thank you for posting.
    Do you mean the paragraph tags or some tags entered by the user?

    Thank you
    brajesh

  • Participant
    Level: Initiated
    Posts: 11
    Kristin on #9162

    I’m referring to the description entered for the media item under the “edit” option in that user’s gallery (using Mediapress). It is entered as normal text, but once saved, appears as html on the edit page. See the screenshot linked here: https://icreatefordolls.com/wp-content/uploads/2017/05/Screen-Shot-2017-05-16-at-1.41.45-PM.png

    The image shows how the description appears after saving. Before saving, it was just “Test pattern description”.

    The appearance of the html is confusing my users and if possible, I’d prefer it remain unseen.

  • Keymaster
    (BuddyDev Team)
    Posts: 22211
    Brajesh Singh on #9163

    Thank you.
    It’s our mistake. While sanitizing data, we made this mistake. I will fix it today and push an update by tomorrow on wp.org.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    Kristin on #9164

    Thank you…much appreciated!

  • Keymaster
    (BuddyDev Team)
    Posts: 22211
    Brajesh Singh on #9203

    Hi Kristin,
    I am sorry for the delayed update. I am pushing it in 30 mins on the wp.org and will post back again.

    Thank you
    brajesh

  • Keymaster
    (BuddyDev Team)
    Posts: 22211
    Brajesh Singh on #9204

    Hi Kristin,
    Please upgrade to 1.1.0.
    It contains the fix for media edit as well as a lot more.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    Kristin on #9246

    That did the trick… thanks!!

  • Keymaster
    (BuddyDev Team)
    Posts: 22211
    Brajesh Singh on #9247

    Thank you for confirming.
    I am glad it is fixed now.

The topic ‘ [Resolved] HTML in media descriptions’ is closed to new replies.

This topic is: resolved