BuddyDev

Search

Moderation Tools: Error When Trying to Make a Report

  • Participant
    Level: Initiated
    Posts: 11
    buddyuser on #46606

    Hello,

    I’m having some issues with the Moderation tools plugin. Specifically, I am getting this error when trying to create a report: “There was a problem. Please try again later.”

    The reports were working the last time I checked, which was a while ago, but not too many changes to the site have been made since. Tried deactivating plugins I could remember that I had installed since, but the error persists.

    I did add Redis and CloudFlare (default settings for free account) to the site since, but doubt that would cause the issue.

    In PHPMyAdmin I see the table exists: _bpmts_moderation_reports, but there is only 1 entry from when it was working before; now with the error response given upon trying to report, no new entries.

    Any idea how to get it working again?

  • Keymaster
    (BuddyDev Team)
    Posts: 21814
    Brajesh Singh on #46608

    Hi,
    I am sorry for the issue. The only reason this may happen is when the database save fails.

    1. is the table prefix same as your other tables?
    2. Which version of PHP and MySQL are you using(You can check it from site health).

    Please share the details and I will assist.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    buddyuser on #46616

    Hi,

    1. Yes, same prefix as the others.
    2. PHP 7.4.30 (Supports 64bit values) and Database mysqli, 10.3.36-MariaDB, mysqlnd 7.4.30

    Server is Litespeed on a VPS

    I cloned the site using Duplicator plugin to a localized copy via XAMPP software that runs on Apache (PHP 7.4.29)(rather than Litespeed). The report function worked on that local copy.

  • Keymaster
    (BuddyDev Team)
    Posts: 21814
    Brajesh Singh on #46619

    Hi,
    Thank you for the details. Do you have same database server/version locally as on the site. I doubt it could be related to database

    Do you have access to php error log? If yes, Please share me the log(last few lines) after trying to report a new entry.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    buddyuser on #46630

    Hi,

    For the local XAMPP version the server is Windows NT 10.0 AMD64, Apache/2.4.53 (Win64) OpenSSL/1.1.1n PHP/7.4.29

    The database is mysqli, 10.4.24-MariaDB, mysqlnd 7.4.29

    For the real site with the report issue, I checked the PHP error logs, assuming this is the standard log file (public_html > error_log), and it doesn’t seem to be creating any error messages when I attempt to report a user and get the “There was a problem. Please try again later.” response.

    There are some recent errors though, one is for Redis not connecting because I’m having some issues with Redis at the moment, the others are below:

    ———————
    [24-Sep-2022 01:16:52 UTC] PHP Notice: Trying to access array offset on value of type null in /home/mysite/public_html/wp-content/plugins/bp-custom.php on line 150

    [24-Sep-2022 01:16:52 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/mysite/public_html/wp-content/plugins/bp-custom.php:105) in /home/mysite/public_html/wp-login.php on line 462

    [24-Sep-2022 01:16:52 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/mysite/public_html/wp-content/plugins/bp-custom.php:105) in /home/mysite/public_html/wp-login.php on line 478

    [24-Sep-2022 01:16:52 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/mysite/public_html/wp-content/plugins/bp-custom.php:105) in /home/mysite/public_html/wp-includes/functions.php on line 6821

    [24-Sep-2022 01:16:52 UTC] PHP Deprecated: login_headertitle is deprecated since version 5.2.0! Use login_headertext instead. Usage of the title attribute on the login logo is not recommended for accessibility reasons. Use the link text instead.
    ——————

    My XAMPP site uses the same bp-custom file, and I also temporarily disabled it on the real site just in case, which didn’t change anything regarding the reporting issue.

    • This reply was modified 1 week, 1 day ago by buddyuser.
    • This reply was modified 1 week, 1 day ago by buddyuser.
  • Keymaster
    (BuddyDev Team)
    Posts: 21814
    Brajesh Singh on #46642

    Hi,
    Thank you for the details.
    Those error do not specify any reason for the issue.

    Do you have any staging environment same as the luve server? If yes, Please allow me temporary access to the site to debug it.

    Thank you
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    buddyuser on #46644

    Hi,

    I have figured out the problem but not the solution.

    It seems the problem is Cloudflare. When I disable Cloudflare entirely from my site, reports now show the “Thank you for reporting” and are appearing in the database.

    When I re-enable Cloudflare, the “There was a problem. Please try again later.” error returns and entries don’t appear in the database.

    For Cloudflare, I am only using the default settings for free account, no custom rules. All parts of site are proxied by CF (by default), SSL Encryption is set to “Full”, Caching level is set to “Standard”, TTL 4 hours — basically, everything is default CF free account.

    When CF is enabled, the page response header shows: cf-cache-status: DYNAMIC.

    I am not using a caching plugin, since I disabled it.

    Do you know why Cloudflare would cause this issue and how to continue using it but have the report function work correctly?

  • Keymaster
    (BuddyDev Team)
    Posts: 21814
    Brajesh Singh on #46649

    Hi,
    Thank you for the details.

    From your response, My guess is Cloudflare is preventing access to wp-admin/admin-ajax.php

    Can you please check it with them and see if there is any restriction?

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 11
    buddyuser on #46689

    Hi,
    Thanks for the response.

    There isn’t any rules I can see (I didn’t add any either), nor do I see wp-admin/admin-ajax.php path having been blocked in the Security Firewall activity log at any point.

    Cloudflare has integrated their “Managed Rules” into free accounts, but turning them off/accessing them doesn’t seem possible on a free tier account.

    In WAF->Tools I allowed my servers’ IP address in case that might help, but that didn’t fix the problem.

  • Keymaster
    (BuddyDev Team)
    Posts: 21814
    Brajesh Singh on #46699

    Hi,
    Thank you for the reply.

    Can you please provide me access to your site(with a guest account). I can check the request/response headers to see if there is any pointer.

    Thank you
    Brajesh

You must be logged in to reply to this topic.

This topic is: not resolved