BuddyDev

Search

[Resolved] New users can not signup with BuddyBoss after installing conditional fields plug

  • Participant
    Level: Initiated
    Posts: 12
    richard shaules on #48356

    Hello there,
    Sorry to trouble you.
    I had installed the BuddyPress conditional profile plugin, and found an error when trying to register new members at http://www.torah.global/register
    There is an error: the new user fills out all fields, hits submit, and is then presented with an error saying “this is a required field” even after all fields have been filled out.
    I’m really stuck here as I can’t have new users join without this problem fixed.
    This issue only appeared after installing the BuddyPress conditional profile plugin. Even after deleting the plugin and emptying cache the issue still remains.
    I’ve had an open ticket with BuddyBoss for over a week but they haven’t found the problem.
    Any assistance would be appreciated- thank you!
    -Richard

  • Keymaster
    (BuddyDev Team)
    Posts: 24188
    Brajesh Singh on #48357

    Hi Richard,
    My apologies for the inconvenience.

    The issue arises if you put the condition on a required field and it gets hidden. Please make sure there is not required field which can be hidden by condition and It will work.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    richard shaules on #48359

    Thank you so very much.
    I deleted the fields all together and the problem still remains 🙁

  • Keymaster
    (BuddyDev Team)
    Posts: 24188
    Brajesh Singh on #48360

    I had a look at your site and i see that “disabled” props is added on your submission button. We don’t do that. last time I found that a security plugin was doing that.

    Any chance you have Wordfence pr something on that line?

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    richard shaules on #48361

    Thanks for the speedy reply- no, I don’t have any security plugins other than limit loginizer

  • Keymaster
    (BuddyDev Team)
    Posts: 24188
    Brajesh Singh on #48362

    You are welcome.
    One of your plugin is adding “disabled” property to the form.
    I will suggest disabling any plugin that affects registration experience. May be temporarily disable the geo plugin that you are using for address to start with.

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    richard shaules on #48364

    Thank you- I’ll try that and let you know asap.
    I disabled the geoplugin but that didn’t effect it.
    I think the error with the required field is in the paragraph text in the “about” section

  • Participant
    Level: Initiated
    Posts: 12
    richard shaules on #48365

    I’ve disabled all plugins except the BuddyBoss platform and the issue still remains..

  • Keymaster
    (BuddyDev Team)
    Posts: 24188
    Brajesh Singh on #48366

    For some reason, when I am using google chrome, your “About” field is not editable/clickable.

    If the issues are still there, any chance you have limited fields to member types and they are present on the first field group?

    Regards
    Brajesh

  • Participant
    Level: Initiated
    Posts: 12
    richard shaules on #48367

    Yes, I have seen that strange behaviour as well with the paragraph box.
    I’ve removed the “about” field and I’m able to submit a new user.
    Any idea how I could further troubleshoot this? The “about” section is critical to new user signup.
    Thank you so very much for your help- you are a blessing!

You must be logged in to reply to this topic.

This topic is: resolved