BuddyDev

Search

[Resolved] User Contact Form – Prefilled sender fields

  • Participant
    Level: Enlightened
    Posts: 41
    Linklusion on #34736

    Hi Brajesh

    I have started to use “User Contact Form”

    A user logged in needs to filled in name and email in the contact form.
    Is it possible to consider to have those fields prefilled according to user (sender) profile ?

    Thanks

    Regards

    Johan

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #34742

    Hi Johan,
    Thank you for the suggestion.

    It’s a great suggestion and yes, let us have it. I will push an update this weekend and will let you know.

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 41
    Linklusion on #34745

    Hi Brajesh

    Thanks to implement this suggestion

    I have a question concerning reCaptcha, your doc says to use reCAPTCHA v2 https://buddydev.com/docs/buddypress-user-contact-form/getting-recaptcha-key/
    Do you plan to user eCAPTCHA v3 ?

    V3 is nice for accessibility ; blind people couldn’t use V2 because the select box is not accessible.

    Thanks

    Regards

    Johan

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #34757

    Hi Johan,
    Thank you for the reply.

    I appreciate your suggestion for using v3. We are unable to incorporate the recaptcha v3 currently. In one of our future release, We will add it along with v2 as an option for admins to let me choose whichever version they want to use.

    Regards
    Brajesh

    PS:- Will be releasing the update today as promised earlier.

  • Participant
    Level: Enlightened
    Posts: 41
    Linklusion on #34760

    Hi Brajesh

    Before you release the update, I want to make a precision
    When I said to have name prefilled, I was thinking to have Display name in field name of the form, not username of sender.

    Thanks

    Regards

    Johan

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #34761

    Hi Johan,
    Thank you.

    Please upgrade to 1.1.4. It is exactly same as you have mentioned.

    Please let me know if it works or not?

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 41
    Linklusion on #34762

    Hi Brajesh

    I have updated 1.1.4, it works !
    Thanks, it is a great improvement !

    I have a backslash (\) when using ‘ (common in french language) in content
    Screenshot https://prnt.sc/vwqj0j

    I don’t have this in email sent through contact form 7
    Screenshot https://prnt.sc/vwqj1k

    Do you have any idea where this issue might come from ?

    Thanks

    Regards

    Johan

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #34763

    Hi Johan,
    Sorry about that. It was a bug on our end. Please use 1.1.5 instead.

    Let me know if it works for you or not?

    Regards
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 41
    Linklusion on #34764

    Hi Brajesh

    It works !
    Thanks for the quick fix

    Regards

    Johan

  • Keymaster
    (BuddyDev Team)
    Posts: 21517
    Brajesh Singh on #34765

    Hi Johan,
    Thank you for the prompt replies and confirming it.

    Regards
    Brajesh

You must be logged in to reply to this topic.

This topic is: resolved