BuddyDev

Search

User Profile Visibility Not Applying?

  • Participant
    Level: Enlightened
    Posts: 89
    Graham Hoffman on #16304
    This reply has been marked as private.
  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16308

    Hi Graham,
    Thank you. I am looking into it and will have some info in next 10 -15 minutes.

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16309

    Hi Graham,
    I have checked it on your site. I see that the saving the settings are not working. It is not saving at all.

    Since you have got more than 50 plugin there, I am going to try on a local multisite install before troubleshooting there.

    I will be posting back in 1-2 hours.

    Thank you
    Brajesh

  • Participant
    Level: Enlightened
    Posts: 89
    Graham Hoffman on #16310

    haha, I thought I was going mad before the videos 🙂

    Any suggestions about the plugin situation? I’m aware people recommend lower amount of plugins but these all add essential functions to my website.

    I mean, my marketplace/sales area has at least 8 plugins from the same developer (Like Extensions) so it’s hard to cut them off.

    There are loads which are not enabled while I’m still testing this site up, which ill remove once I’m confident I don’t need them, but just wanted to get your opinion on it.

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16315

    Hi Graham,
    The Essential grid plugin is not allowing our post meta to be save. I disabled it and it started working.

    Most probably the plugin is tainting our data( or I am not sure, is it also using cmb2 and may be causing some conflict)

    About the plugins:- The number of plugins won’t be an issue from speed point of view(It depends on how much resource intensive they are) but it is surely problematic while doing updates and all.

    I will suggest using a plugin like WP Staging to create/test updates before committing on the site. Also, using a plugin like VersionPress can help you troubleshoot much better in the long term.

  • Participant
    Level: Enlightened
    Posts: 89
    Graham Hoffman on #16316

    Oh, I’m 100% using a staging ground – this website itself is staging rather than my live environment 🙂

    Okay, Essential Grid is part of my theme although its not actually activated right now…?

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16317

    That’s good to know.

    Yes, I have deactivated it. Please try adding/removing tabs now.

  • Participant
    Level: Enlightened
    Posts: 89
    Graham Hoffman on #16318

    Ah, that makes sense. and it works perfectly!

    Any suggestions what to do if I did need Essential Grid? Or is it a case of tough luck for now?

    I’m not specifically using it yet, well it’s on the homepage but I can tweak it if it’s causing a pain.

  • Keymaster
    (BuddyDev Team)
    Posts: 21785
    Brajesh Singh on #16319

    It is a bug caused by the Essential grid. Please contact Themepunch team and ask that the plugin is not allowing meta to be saved for another plugin using CMB2.

    If they say that it is not caused by their plugin, Please point me to the topic and I can prove it for them.

    Also, I had a look at the code 2 year ago when Essential grid took down the site of one of my clients(Yes, It loaded 35000 posts while only showing 20). Sorry about this, but I will try to avoid playing with their code again.

You must be logged in to reply to this topic.

This topic is: not resolved