BuddyDev

Search

Replies

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #39678

    Hello Brajesh,

    Thank you very much for your reply.
    I have the same template in local and on line: the Legancy Template.
    The website has been just migrated yesterday. I have exactement same copy, no change. In local, it is working very but not in sever. Don’t you think it might be related to the server?

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35670

    Hello Ravi,

    Thank you very much. It works for me! Thank you for your help.

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35668

    Hello Ravi,

    Thank you for your reply to this Daniel’s post. I am interested in the question but I am using Legacy. How can I modify the code?

    Kind regards,

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35286

    Hello Ravi,

    It was effectivelly the mater of template override. In my case, it was du to the presence of the js\buddypress.js template in my theme (oceanwp-child-theme-master\Buddypress\js\buddypress.js). I added this missing new additional code '_' + form_id[2] to
    to
    ` ajaxdata = {
    action: ‘new_activity_comment’,
    ‘cookie’: bp_get_cookies(),
    ‘_wpnonce_new_activity_comment’: jq(‘#_wpnonce_new_activity_comment’).val(),
    ‘comment_id’: comment_id,
    ‘form_id’: form_id[2],
    ‘content’: content.val()
    };`

    like this

    
    
     ajaxdata = {
    action: 'new_activity_comment',
    'cookie': bp_get_cookies(),
    '_wpnonce_new_activity_comment': jq('#_wpnonce_new_activity_comment'+ '_' + form_id[2]).val(),
    'comment_id': comment_id,
    'form_id': form_id[2],
    'content': content.val()
    	 };  
    
    

    The problem is therefore solved. I would like to thank you, Ravi and Brajesh, for your help. Thank you very much.

    Regards,

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35147

    Hello Ravi,

    Thank you again.

    As discribed in the link you joined in your reply, I have put the following code in wp-config.php .

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 ); 

    The “debug” file is only created when starting the website. So the response to comments does not appear in it:

     [29-Dec-2020 16:44:24 UTC] PHP Warning:  mysqli_real_connect(): (HY000/2002): Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.
     in C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\wp-db.php on line 1653
    [29-Dec-2020 16:44:24 UTC] PHP Stack trace:
    [29-Dec-2020 16:44:24 UTC] PHP   1. {main}() C:\Users\User\AppData\Local\Programs\Local\resources\extraResources\bin\wp-cli\wp-cli.phar:0
    [29-Dec-2020 16:44:24 UTC] PHP   2. include() C:\Users\User\AppData\Local\Programs\Local\resources\extraResources\bin\wp-cli\wp-cli.phar:4
    [29-Dec-2020 16:44:25 UTC] PHP   3. include() phar://C:/Users/User/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/php/boot-phar.php:11
    [29-Dec-2020 16:44:25 UTC] PHP   4. WP_CLI\bootstrap() phar://C:/Users/User/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/vendor/wp-cli/wp-cli/php/wp-cli.php:27
    [29-Dec-2020 16:44:25 UTC] PHP   5. WP_CLI\Bootstrap\LaunchRunner->process() phar://C:/Users/User/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/vendor/wp-cli/wp-cli/php/bootstrap.php:74
    [29-Dec-2020 16:44:25 UTC] PHP   6. WP_CLI\Runner->start() phar://C:/Users/User/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Bootstrap/LaunchRunner.php:23
    [29-Dec-2020 16:44:26 UTC] PHP   7. WP_CLI\Runner->load_wordpress() phar://C:/Users/User/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php:1158
    [29-Dec-2020 16:44:26 UTC] PHP   8. require() phar://C:/Users/User/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php:1237
    [29-Dec-2020 16:44:26 UTC] PHP   9. require_wp_db() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-settings.php:124
    [29-Dec-2020 16:44:26 UTC] PHP  10. wpdb->__construct() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\load.php:527
    [29-Dec-2020 16:44:26 UTC] PHP  11. wpdb->db_connect() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\wp-db.php:632
    [29-Dec-2020 16:44:26 UTC] PHP  12. mysqli_real_connect() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\wp-db.php:1653
    [29-Dec-2020 16:44:29 UTC] PHP Warning:  mysqli_real_connect(): (HY000/2002): Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.
     in C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\wp-db.php on line 1653
    [29-Dec-2020 16:44:29 UTC] PHP Stack trace:
    [29-Dec-2020 16:44:29 UTC] PHP   1. {main}() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-admin\index.php:0
    [29-Dec-2020 16:44:29 UTC] PHP   2. require_once() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-admin\index.php:10
    [29-Dec-2020 16:44:29 UTC] PHP   3. require_once() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-admin\admin.php:34
    [29-Dec-2020 16:44:29 UTC] PHP   4. require_once() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-load.php:37
    [29-Dec-2020 16:44:29 UTC] PHP   5. require_once() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-config.php:77
    [29-Dec-2020 16:44:29 UTC] PHP   6. require_wp_db() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-settings.php:124
    [29-Dec-2020 16:44:29 UTC] PHP   7. wpdb->__construct() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\load.php:527
    [29-Dec-2020 16:44:29 UTC] PHP   8. wpdb->db_connect() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\wp-db.php:632
    [29-Dec-2020 16:44:29 UTC] PHP   9. mysqli_real_connect() C:\Users\User\Local Sites\vulgariser-les-maths\app\public\wp-includes\wp-db.php:1653 

    I don’t if I did what you asked for.

    Regards,

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35131

    Hello Brajesh,

    Thank you very much for assistance.

    When a comment is added after opening the network tab, the request send to wp-admin/admin-ajax.php is most of the time “failed to load response data” (admin-ajax.php appears in read). After about ten requests the response is something like
    {"bnb-data":{"messages":[],"last_notified":0},"wp-auth-check":true,"server_time":1609106046}.

    Regards

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35076

    Hello Ravi,

    Thank you again!

    Here are what I am getting while the reply button is clicked: There are several admin-ajax.php. And it is still appearing.

    The response in the first is:
    {"bnb-data":{"messages":[],"last_notified":0},"wp-auth-check":true,"server_time":1608835280}
    At this moment, the lastest is

    {"bnb-data":{"messages":[],"last_notified":0},"wp-auth-check":true,"server_time":1608836533}

    Regards

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35064

    Hello Ravi,

    Thank you again!
    The website is still in local. I am developing it using Local by Flywheel. So, I don’t know if it is possible to provide a temporarily guest account for someone in local installation. If yes, how can I do it? It can do anything you ask for; I really need to solve the problem.

    Best regards,

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #35011

    Helo Ravi,

    Thank you for your quick reply. I can view the comment form and I am not getting any error. When the comment form appear and I type a text and click to reply button to send the comment, the buton stays clicked indefinitely and doesn’t send the text.

    Regards

    Nestor

  • Participant
    Level: Enlightened
    Posts: 25
    Nestor Djintelbé on #30509

    Thank you very much! I will contact them.